Loading Album Problem

(Nucleus here)
When I search for Tom Waits, I see the Albums listed (images) and when I click on one there is the endless ROON icon mentioning “Loading Album”, never loads it.
As a debugging trial I clicked the right mouse button while being on the album image which makes the blue “play now” button appear at the top-left of the screen and when clicking that button the Album is being played.

Can this be solved?

1 Like

I have started to get exactly the same issue - albums listed under artist, click on one and the “Loading Album” icon shows but never loads although right-click and “Play Now” plays the album fine.

Running Version 1.7 Build 667 Stable 64-bit with a Win10 Core server.

Sorry I don’t have a solution, but you’re not alone with this problem.

A full reset/reinstall solved it again (but might happen again)

Is it library size maybe , my 130k tracks eats up nearly 5gb of RAM

With an internal huge SSD I wouldnt expect that since I dont have that much albums in my list