Logitech Transporter : How can I enable SPDIF output?

Hi there,

This is an old machine but wanted to run Roon with it.

I only use the Transporter as a digital bridge between my Mac Mini and my Processor.
I must enable spdif RCA out on the Transporter so my processor can convert.

I can’t find the options to do so.

Can you help ?

Much appreciated :slight_smile:

I think the output control is in the Transporter menu system, not Roon.

1 Like

Despite the Transporter connects to roon successfully, I can’t browse the unit’s menu system… or anything else.
PLAY, PAUSE, NEXT, PREV seems to respond but no sound …
Too bad !
Thanks anyway

I have a transporter but don’t use it with Roon. There is one place I see in the Transporter where I tell it to output S/PDIF rather than AES. Perhaps once that is set in LMS it stays the same. Start LMS, go to LMS > Settings > Player. Choose the Transporter as player and for “Digital Output Encoding” choose S/PDIF from the dropdown menu. Perhaps once set, it will retain that setting when you later connect it to Roon.

With the Transporter, I also have controls regarding S/PDIF regards turning on INPUT to the Transporter. That is, I have a rasberry rPi with S/PDIF output, and I can connect that to the S/PDIF input on the transporter in order to use the Transporter DAC (and in this case I have to select S/PDIF as the digital input for the Transporter). But again, this is all about digital INPUTS (AES, S/PDIF BNC, S/PDIF RCA, Toslink).

1 Like

i believe if you press the “back” arrow on the Transporter remote the menu system will come up. this should allow you to navigate to the digital output encoding garym mentions w/o needing to use LMS.

2 Likes

Hi,

I’m running Logitech Media Server Version: 7.9.2 - 1578727069 and roon (latest version).
MacOS 10.13.6 hosts both apps.
All disks except one use APFS file format, which works fine with LMS.

I stop LMS before starting roon to avoid conflict.

The Transporter won’t keep the settings from LMS once connected to roon.

Thanks for taking the time !

Seems odd, as several people use Transporters within Roon. But maybe they are all using the Transporter as an endpoint streamer/DAC, ultimately connecting the Analog outputs to their stereos. I think you are using your Transporter as a transport, but not using its internal DAC and analog outputs. Perhaps no one else is using this way, thus no reported problems. In any case, I’m out of ideas.

1st try didn’t do it
When you use back (long press to get it work) you get the Transporter disconnected from any server …

2nd try
I managed to reconnect to roon retaining the settings.

Now I get some fine sound !

Many thanks !

2 Likes

Excellent! Enjoy the music. I know I love my old Squeezboxes.

Thanks !
:smiley:
one last question : where can I get extensions ?
Fo example I did a little search to access roon from my laptop (I’m running the Mac Mini hosting roon, head less) a plugin called Web Controller v1.2.0 seems to do the trick but I don’t know where to get it nor how to install…

Hmm. I am not sure why you would need that as opposed to just running a Roon Client on the remote device. Just load Roon on the laptop and instead of installing the full version that includes the server portion, just install it as a client to the server running on your mac mini.

1 Like

roon is smarter than expected !
This solves my problem :slight_smile:

Thanks +++

1 Like