Losing connection to Bluesound devices


(Sascha T.) #1

Even though this thread is old, I’m gonna revive it @mike I’d be curious to hear if there have been any updates and if you are aware of similar issues with the new 2i line of products from Bluesound.

I’m having the exact same issues with my four Bluesound Pulse Flex 2i. The speakers will eventually drop from Roon but they are still usable via the BluOS app and Airplay 2.

Data:

  • Stable n/ac network (Fritzbox 7590 + 1750E Repeater with Mesh networking latest 7.01 updates), covers my whole apartment
  • ROCK running on Intel NUC7i7BNH
  • 2x Ropieee RPis (2 Devialet Phantom Golds with HifiBerry Digi+ Pro / Dragonfly Red + h/k SoundSticks)

Roon keeps losing connection to Bluesound speakers
#2

I don’t suppose this has anything to do with the Fritzbox configuration? I remembered it has a specific config requirement on https://kb.roonlabs.com/Networking_Best_Practices#Router_Specific_Settings

Probably entirely unrelated but thought it worth mentioning.


(Sascha T.) #3

Interesting. Thanks for the pointer :upside_down_face:. I’ve went ahead and disabled both the general “Packet Acceleration” as well as the “Hardware Packet Acceleration” in the FritzBox settings. Will report back here.


(Sascha T.) #5

The problem persists with “Packet Acceleration” disabled. I’ve gone ahead and removed the repeater from the equation and rebooted the FritzBox. Same issue. Next thing I’m trying is a power cycle of all the Pulse Flex 2i devices, which looks good so far. It has only been two hours, though :wink: Let’s see what this day brings :crazy_face: :headphones:

Edit: Probably not super important, but here’s how it looks like when Roon loses sight of the devices. “Schlafzimmer” and “Wannenbad” (:sweat_smile:) are two of the four Pulse Flex 2i. Maybe turning on logging would make sense here. Right now I’m not seeing the issue after the power cycle, but it has only been 2,5 hours now.


(Dylan Caudill) #6

Hi @saschamt,

I’m glad that so far things are working for you now, definitely let us know if you see this behavior again. Removing the repeater and disabling packet acceleration are definitely good steps to take here, so that along with the reboot may have resolved things.


(Sascha T.) #7

Thanks @dylan. Unfortunately the issue reappeared this morning. Would it make sense to turn on logging for my account to get to the bottom of this? I’m very happy with Roon as a lifer but this problem really takes the joy out of the equation :no_mouth:


(Noris) #10

Hey @saschamt,

Sorry to hear the issue reappeared. I wanted to jump in here since Dylan is on leave for a bit, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

I kindly ask for you to reproduce the issue once more and note the exact local time in your country (ex. 10:08PM) that you notice the issue occur at. I can then cross reference the diagnostics with your timestamp and see if Roon is outputting any errors at that time. Please let me know this info and we can continue troubleshooting from there.

Thanks,
Noris


(Sascha T.) #11

@noris thank you for jumping in. I was able to easily recreate the behavior both with local FLAC files (44.1 kHz 16 Bit) and with standard Tidal FLACs.

I’ve selected all of my speakers and grouped them. The four Bluesound Pulse FLEX 2i and the two Roopieee installations. Music started playing after a couple seconds but two Bluesound speakers were lost:

[7:24am CET]

After roughly a minute or two, Roon seems to see the speakers again and STOPS PLAYBACK:

[7:25am CET]

Hitting play then resumes music playing. The weird thing is that in addition, sometimes the Bluesound speakers will not even output sound even though Roon reports them as playing.

For kicks I’ve also tried to only group the Bluesound speakers. Exact same issue.

Edit: Another lost Bluesound speaker now, even though I wasn’t even using grouped playback:

[7:45am CET]


Bluesound Gen 2i wireless speakers
(Sascha T.) #12

@noris @support

I’m fairly confident that the issue lies with the Bluesound devices themselves now as I have bought a Netgear Orbi system on trial and moved my whole wireless network to see if it is the network that makes the devices drop from Roon. It is not, unfortunately. Hope the logs can clear some of this up. I can probably return the four speakers tomorrow but I shouldn’t wait too long. This is unacceptable unfortunately :zipper_mouth_face:


#13

It seems unlikely that you’ll resolve this in the space of a day, given that you’ve probably eliminated most of the obvious network issues by moving to the Netgear Orbi (or there’s something very odd happening which means they’ve propagated across). If this were me, and this were my last chance to return, I’d seriously consider doing so. If the fault indeed lies with the Bluesound/Roon interaction then past experience has shown that this could take quite a while to address, if at all, and you may not wish to chance that. The frustration is there isn’t anything else out there quite like the Flex (RAAT, same form factor, same price).

Edit: OOI does it still happen if you group the speakers in the Bluesound App but then play via Roon?

Edit 2: It’s worth checking out this which suggests that the very recent BlueOS update would be worth at least trying (though it’s a slightly different issue).


(Noris) #14

Hello @saschamt,

Thanks for trying with a different router. Just a thought but if you Disable IGMP Proxying for your Orbi router as noted in Networking Best Practices Guide does that have any effect on the grouped playback? Are the Bluesound devices on the newest firmware?

As for the timestamps you mentioned, I am noticing the disconnects but there does not appear to be a specific reason as to why, the logs just show failed to connect Connection refused. I will also get these logs over to QA to take a look and will let you know if they can ascertain anything different than what I have.

Streaming to multiple zones is an intensive process and while we’re happy to work with you here to diagnose the issue, it may take a bit of time to have the logs analyzed by the QA team and have next steps in place, this is just something to consider if the return window is closing. I have however added your case to the review queue and I will be sure to let you know as soon as hear back from QA regarding this issue.

Thanks,
Noris


(Sascha T.) #15

Thanks @noris. The devices are all on the latest firmware 3.2.6. I’ve reproduced the issue with both IGMP Proxying on and off. I’m going to try @dhusky’s suggestion to group all the speakers via BluOS and then play back via Roon just to see if that makes a difference. I’ll also try another hardware reset. And then I’m considering my options…


(Sascha T.) #16

Some more things I’ve tried, all with the same core issue happening again and again:

  • Factory reset all Bluesound devices, not touching any custom settings afterwards
  • Remove any fixed IP & network name customization from the speakers (in router interface)
  • Disabling and re-enabling the devices in Roon
  • Grouping all four Bluesound devices with BluOS, playing back via Roon
  • Grouping all four BS devices with Airplay 2 and playing back via Tidal — no issues at all
  • Restarting my Router, restarting all the devices in the network

At this point I’m returning them to the store while I can. Quite bummed about this, as the feature combination and sound where ideal for secondary/tertiary listening rooms. I’m probably going to use RPi+HAT+Ropieee installations with some “non-smart” (dumb? :laughing:) speakers now…

I’d be interested to hear what QA says about this issue, but unfortunately I cannot really wait. With all the different things I’ve tried, I can hardly imagine that this is an exclusive issue.

EDIT:
I’ve returned the speakers to the store for full credit and bought some passive speakers that I plan to run with a RPi+HifiBerry-AMP2+Ropieee config. Thanks HiFiKlubben for an easy return!


Standalone, compact Roon Ready Player/Speaker - what options?
#17

Although you’ve now returned your Bluesound devices, I wanted to add that you are not alone in these issues. When I had Orbi, I had Bluesound players randomly drop off the controllers (iOS, Roon and iMac) and only rebooting the players would bring then back (sometimes not even then). Yep, that gets annoying over time.

I moved to Plume Wifi, and things have been somewhat more graceful. If the players decided (using their own crazy logic) to move themselves to a different mesh node, they would still drop off the controller apps; Plume had to disable client steering for all Bluesound devices. Bluesound logic (wifi, we are talking) is a bit mad, the players will choose to connect or move to a much weaker pod (plume call their nodes ‘pods’) and then they would just drop off the network. I have things mostly stable using plume wifi (I only ever group in the bluos app and not Roon). Now, if they do ‘move around’ wifi mesh nodes, they will, at least, stay visible to the bluos controllers. The players would then still have to be rebooted to returned them to a node that can give a better signal to the Bluesound player.

I have always suspected that Bluesound’s wifi firmware to be somewhat troublesome, and I don’t think they like mesh systems very much either. Hardwire the things and they are perfect. Dropping players is rather too frequent on their support community and their forums. Then again, I think Sonos has similar trouble, and that’s why their players can create their own mesh.

When I can, I plug Bluesound into the ethernet port of the satellite mesh nodes (pods). And those plugged in cause no trouble at all.


(Sascha T.) #18

Great to hear you’re getting by with your Bluesound devices. I’ve done what I said and installed Pi+HAT+Ropieee+Speaker combinations in the rooms previously filled with Bluesound devices and I haven’t had any issues with drop outs. Not even once. Super happy with this new setup now.


(Noris) split this topic #19

A post was split to a new topic: Bluesound Node Disappears