Losing connection to Roon Core

Hi - I’ve seen this question asked several time – but I have not found any solution recommended or suggested.

I’ve been using Roon for two weeks – and reluctantly signed up for a lifetime membership – hoping that the problem I’m having will be resolved - either through support - or with an eventual update - but i’m getting increasingly frustrated

I am constantly getting a dropped connection - with a message that says - “LOST CONNECTION TRYING TO RECONNECT - SELECT ANOTHER ROON CORE”
This will last for 30 seconds sometimes – or up to 3 to 5 minutes & then it finds the core and I can push Play to continue – but it has never played for more than two hours without loosing the connection – and it is not happening when transitioning from one song to another – or one album to another ( where resolutions might differ) - it happens in the middle of a song - randomly. I also never have to reboot the music player to get the connection back – it just comes back on it’s own – but does not resume playing – I have to hit the play icon.

I’ve had a networked music system for 7 or 8 years – using LMS devices ( a Transporter, two Touch’s and a Squeezebox radio) & I’ve never had connection issues with these devices - even when running wireless and with a fairly large library. I also used Daphile on the same hardware ( a different boot hard drive - but the same OS ) for 8 or 9 months just before using ROON and again - never experienced the drop outs. I still have LMS available on the QNAP server – and playing it with all the same network set up - does not present any problems ( I have not tried using the LMS as endpoints with Roon yet – I understand that’s an option – but I want to get the basic Roon system running properly first )

The set up is all hardwired Ethernet CAT 6 –
Sagecom Fast 5520 Modem / 4 port Hub
32 TB QNAP server with roughly 16,000 albums - networked to an HP1410-16G 16 port Switch
A cable run of about 20 ft into another room - where it connects to a Lampizator Komputer ( dedicated headless music PC running on Linux with Roon Core installed )
Lampizator Komputer connects to a Lampizator Big7 DAC with a premium Dana USB cable

I have tried bypassing the HP switch and running the Ethernet cable directly from one of the Modem ports to the Lampizator – and I get the same results & the same message.

I have a desktop PC that I use as a control PC ----- I’ve also installed remotes on an iPhone – and an Android Tablet – but the drop outs occur regardless of the remote or interface I’m using – the iPhone and Android Tablet are typically off when I’m listening to music – but if any of the controls are on – it doesn’t change the frequency or duration of the drop outs – the same message comes up at the same time – and resolves at thew same time on all the devices.

I’ve tried re-installing the software on the desktop PC – but I have zero experience or comfort with Linux – so I can’t see what might be going on in any log files like I could with LMS Squeezebox devices.

Seems to me that there is an issue with the “handshake” between the Core and the DAC – but I’m only guessing.

Any guidance you can provide would be helpful – as I’m sure I’m not the only one experiencing this & I would love to be able to enjoy the great interface Roon provides.



1 Like

I have the same thing occurring (others too if you read through the posts) and mine is definitely when sample rate change occurs between songs/albums. Core may not restart when a song starts, but can occur during a song as you have seen. If I reboot CORE and play the same sample rate, it can play fine for hours (for instance using streaming radio).

Roon has informed me it is addressed and working, and the fix will be in v1.3

Thanks for the reply Dan – being new to Roon – do you know how often they revise the software – or any idea when V1.3 might be released ?

Danny just answered this in another thread.

Hi @Bart_Gilchrist ----- My apologies for the troubles here, and thank you for the report. Can you please confirm for me if you notice the same behavior when using the WASAPI driver?


Hi Eric – I don’t believe I have any way of doing that – the Core runs on a dedicated headless Linux PC –
According to Roon – it is using the ALSA driver in the Player — but the DAC uses a Combo 384 Amanaro driver for the USB input


Sorry – the player uses a Combo 384 Amanaro USB card and driver for the output – not sure what the input driver on the DAC is ----- it might be the same – but they are both built by Lampizator – so there is not question that they should be compatible. Again – I’m helpless with Linux – I had Lamizator send me a new hard drive with the OS and Roon pre installed and tested – I just swapped it out for the drive previously used that was optimized for Daphile ( again Linux OS)


Hi @Bart_Gilchrist ----- Thank you for the follow up and the feedback. Both are appreciated! I’d like to gather some logs from you so our developers can have a closer look into this issue for you. I will be contacting you via PM momentarily with instructions.


I had same problem, lost connection. I use a computer with Roon an iPad remote and a T+A MP2000R multiplayer with DAC.
I had a Ziggo router AND a separate Linksys WiFi point, both of them where giving IP adresses to the devices in the network! That was the problem on my system. I set the Linksys to stop giving IP adresses, it is just a switch with WiFi. The Ziggo router is the only device giving out IP adresses to the network, and the problem was gone.

Hi Eric

Where do I send the file – for 119304ac-c714-4157-b514-ce82b7c38605 –

This msg board won’t allow attachments – I tried to reply to the e-mail you sent me but it bounced back

The time that it stopped was at 1:55 pm – searched for core – took about 30 seconds – had to push play to start again
Then again at 2:18 – stopped for 3 seconds then started again on its own
Then again at 2:23 – stopped for about 30 seconds again – had to push play to restart

I did not have to restart the core in any of these instances

Note – the OS was installed in Poland – so there might be a 5 hour time difference on the time stamps – I’m in Toronto


Hi @Bart_Gilchrist ---- You shouldn’t have to send the support package anywhere as it will automatically upload to our servers as seen here. All you need to do is enter the id when prompted on your remote device and we should receive the logs from both the remote and the core.


Hi @Bart_Gilchrist ----- I wanted to touch base with you as I haven’t received the support package containing your logs yet. Let me know if you need assistance with this process.


I thought it was sent automatically when I filled out the support page – I have a copy of it on my desk top – how do I get it to you – thanks


Hi @Bart_Gilchrist — I am going to follow up with you via PM momentarily.


Hi Eric
Support package was sent – the player stopped at 4:17 and had to be restarted – and a few other times - roughly an hour before that - but I didn’t record the time



1 Like

I just started my Roon Lifetime in December. This behavior occurs often from my mobile phone remote app for no apparent reason. I do know all my indicator lights on my NETGEAR xs708t 10gbe network switch that connects my 2 blade servers and my Raid10 array and backup Raid5 array to the network, blink in unison when this happens, but it’s not the switch as I’ve already had it swapped for a new one. Typically this behavior would indicate a loop or broadcast storm in the switch, but I know there’s no loop. Maybe a broadcast storm caused by Roon?

PS: As an aside, Roon not supporting jumbo frames is very odd and frustrating for the average end user to troubleshoot. I only isolated that issue through an educated guess after eliminating all other network related possibilities. This should at the very least be documented somewhere. Hopefully someone with this issue will Google and find this and it will help them.

Hi @Wh01sjongalt ----- Thank you for the report and my apologies for the troubles here. To help me better evaluate this issue may I kindly ask you to please provide the following information:

  1. A brief but accurate description of r your current setup as seen here. The more detailed you can be, the better.

  2. Have you always encountered this issue with your Roon remote or is this a recent observation that has been made? If this is indeed a recent occurrence, can you think of any changes that may have been made to your setup recently that would have impact on this behavior being noticed?

Lastly, I notice from your report that you are making use of a managed switch in your network configuration (NETGEAR xs708t). I will advise that we have seen issues in the past a rise from working with managed switches as there could be multicast package filtering going on (More examples: #1 and #2).


I have the latest version of Roon Core Server x64 for Windows installed on a Dell PowerEdge R620 server. That server is connecting to ~27TB Raid10 via a HBA to a SAS Expander housing 15x4tb drives. I also have a separate Dell PowerEdge R420 server being used as a Synology NAS, but it’s just for backup, mirroring, redundancy of my media files stored on the R620 server. It has 4x10tb HDDs in a raid 5 for storage, but again has nothing to do with Roon, unless the R620 server goes down. I also have my main gaming rig. All three are connected via cat 7 to the netgear xs708t NETGEAR switch which is managed. This switch was the most basic 10GBE switch I could find with sfp+ and Ethernet Jack’s to support all three nodes at the fastest speed to expedite multi-tb media file moves. IGMP & MULTICAST is disabled on it, unless I’m missing something. The behavior with Roon has occurred since day one. My router is just a descent ASUS router that provides dhcp and WiFi to my network located in another closet. The router is linking the NETGEAR switch and my other nodes through a Cisco unmanaged switch and from there it goes directly into the NETGEAR switch.

To clarify: Internet Gateway>ASUS WIFI Router>Cisco Dumb Switch>NETGEAR xs708t managed switch>Dell R620 server/Dell R420/COSMOS Gaming Rig. My remotes are my LG V20 Android phone running Nougat, and I have roonbridge and the Roon GUI app running on a Win10 Lenovo Tablet in my main listening room connected via a generic and separate dumb switch via Ethernet back to the aforementioned Cisco dumb switch in my wiring cabinet. I have one HIFIBERRY in another zone connected to another Cisco dumb switch via Ethernet that connects back to the aforementioned original Cisco dumb switch. My COSMOS Gaming rig is a 3rd zone Running both Roonbridge and the GUI APP via WIN10 connected via 10GBE CA to back to the XS708T NETGEAR switch.

Hi @Wh01sjongalt ---- Thank you for the follow up and taking the time to answer my questions, both are appreciated. I touched base with my developers today to get some feedback on this behavior you are noticing and they have asked me to gather some more information from you to help clarify some things. Please see below.

  1. Please verify the exact behavior you are experiencing with your mobile device.

  2. Can you please provide the exact model of ASUS router being used.

  3. The behavior you have noticed with your phone acting as a Roon remote, is this being displayed on any other devices acting as remotes?


You’re most welcome and thanks for the support!

  1. While using the Roon App or returning to the Roon App on my smart phone, the application loses comm. with Roon and tries to search for it while indicating it’s take longer than it’s supposed to. If I observe my Netgear XS708T 10GBE Switch when this happens, all the ports lights blink in unison for a period of time. Once the phone regains connection to Roon (Times Vary from 15 Seconds to several minutes) the switch seems to calm down and go back to blinking normally, but invariably this will come back and only sometimes cause the Roon remote to disconnect intermittently) Sometimes I can go long periods of time (hours, sometimes many hours) and everything is copacetic with both Roon Remote and the switch. Don’t get it twisted thinking it’s correlative because sometimes the remote app disconnects and the switch is oblivious or already finished having a conniption fit, but more time than not when I lose connection and look at my switch the two seem to be having a battle of contention.


3)The other windows 10 machines (COSMOS and X201T Tablet) acting as remotes using the Windows Roon App - nearly always are oblivious to the phones remote connectivity issue, but I have seen the X201T machine disconnect, but usually never when the Phone is going full retard, at least not in any noticeable way.

  1. Bonus: Please …don’t blame my wifi, it’s done nothing wrong. It serves me up hot packets nearly always without any weird connectivity problems or signal strength issues. Yo, I get mad bars of signal strength everywhere in my home. (sorry for the colloquialism)