Lost all audio devices, reboot of core and router doesn´t help SW 1.8 build 783

After 2 long working days I hoped to enjoy some music… This is my first major issue with Roon. I lost all audio devices, pc , tablet , phone, raspberries, Brystons BDP, … nothing can be found… I did full power downs of the core and router (provider). The core is a W10 headless unit.

1 Like

Moved this to support for you

Verified firewall settings, all communications are allowed for Roon and Raatserver.
Problem unsolved at this time. Roon also extremely slow to start.

Reinstalled software,… without succes
Still no audio devices available. Even local device on W10 based headless unit is not detected. Also devices duch as Windows surface and Android 10 based phone remain undetected.

A post was merged into an existing topic: No audio device can be found

I’m up and running again. It took all weekend to figure out. First of all: People keep your backups from SW 1.8 build 753 or earlier. Backups of build 778 and 783 are not working in case you have to reinstall SW 1.8 including erasing the database. I had to do this because since build 783 (sure), possibly since build 778 (not 100% sure) all my audio devices were undetected and Roon was loading very slowly. If loading at all. It all started with me trying to play some music after a hard week of work. Unfortunately all of my audio-devices were gone, also the internal soundcard of the core was nowhere to be found. This made me suspect something with the software. Of course I did check firewall and network settings, but my Roon-dedicated headless W10 machine (Dell Optiplex 9020M based i5 @2GHz, 4 cores, 8GB, hybrid HDD) has been running with no issues at all since 2016. Of course a defect or windows update can change things, but I had no reason to believe that was the issue. Resetting network, rebooting core, restarting audio devices,… Nothing helped. Finally I concluded it had to be software related. At first I uninstalled the software, leaving the database. I downloaded the software from the site, but soon found out no audio devices were detected as well. So I uninstalled the software again, including the database. I had a recent backup, so that shouldn’t be a problem. Wrong! None of my backups since build 783 worked, at best I got no audio devices, … So exactly the situation I was in before. Same happened when using build 778 build backups,… Finally and luckily I found a 753 build backup from early februari 21. That worked!
So,… PLEASE ! Roon support don’t just tell people to reboot everything and to check their network and firewall settings and close the error-report! Something is really wrong with build 778 and 783 of sw 1.8 ! I have been an early adopter since 2015, I convinced a lot of people to use Roon. But this problem and its support is very sub-standard of Roon. I like SW 1.8, but please test your builds ! The last ones are rubbish!

1 Like

I’m glad you’re back up working again. Your solution does seem to point out a strange issue that seems clearly Roon related.

Hopefully what you have discovered will help Roon devs work out a solution for others.


1 Like

Exactly the reason why I posted my solution. Maybe specific to my situation,… but MAYBE it can help others.


Hi @WimJ

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

I’m glad to hear that things are working for you now. It sounds like something might have happened to your database that caused an issue that wasn’t in some of the older backups. If you make a new backup and try to restore it does it work for you?

Since I am far from the only one having this problem, I have my doubts about the very latest software builds, please check to avoid these kind of problems. It is not up to your customers to spend three days of finding, analyzing and correcting software problems.
This was a major issue, not just a colorscheme I didn’t like. NO audio devices were found! Not one note of music could be played.