Loud Pop on my speaker when switching songs

Depends on the platform, but Android and iOS you just use the screen capture app, on Android its power button and volume down and on iOS it’s power button and volume up.

You will see the signal path like below.

Here is what I see is in the signal path

And I can’t figure out what is optimizing for speaker settings… DSP is completely turned off in Roon

That is strange, distance is normally set in DSP (see screen shots) if it’s not visible it shouldn’t be active. But you can add the filter then disable it to make sure.

Thanks for that, when you get a pop do you know if you are playing a track at a different resolution so you can use the signal path to see. I would expect if you played a 24/48 or 24/192 track that it would engage DSP to make the track 44/16 and thereby keeping al the music on the same digital output path and saving the DAC from having to switch.

This is only an assumption on my part that it is this causing it.

Some people use DSP for setting their Roon outputs to upsample everything x2, but first it’s good to find out if this is actually your issue.

Change in resolution was the problem in my case, resync delay of 500mS resolved it.

1 Like

Hi Paul, did just the resync on it’s own fix it or did you need to send as a fixed resolution (either everything at 16/44 or everything at 24/96).
Could be useful in OP understanding the changes? I have seen both options recommended in different places but never had the problem myself.

Hi Michael, I didn’t change the resolution at the time as I had read somehwere (in the community) that resync delay settings might resolve the popping. It worked & disabling the resync reverts to popping sounds, that said I haven’t retried for a few months.

Prior to that time I hadn’t changed resolution, since then I have been sending everything to Mscaler at 48khz to force the highest rates.

1 Like

Thanks Paul, hopefully this information will help

Been playing around with this a bit more…

Most times it happens when I skip between Tidal/Qobuz. I can’t really establish a genuine pattern.

Just now I was playing Tidal 24/48 MQA and skipped to Qobuz 24/48 and it popped.

1 Like

You sure that wasn’t vinyl popping you heard :thinking::man_facepalming:t2:

2 Likes

Hi @Prasenjit_Biswas ,

Are you still seeing this issue at the present time? Are you using the latest firmware according to the BluOS app? If you try to use Roon’s DSP to upsample all songs to the same sample rate, do you still notice the issue occur?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.