Loud white noise on headphones with RoPieeeXL and Pi2AES-Lite throw COAX

Hi there!

When I try to play music to my RoPieeeXL end point through Roon, I get extremely loud white noise out of my DAC to my system. I prefer reading and writing bullet lists of relevant info, so see below for the details.

RPi info:

  • RPi Model: Raspberry Pi 3 Model B Rev 1.2
  • RoPieeeXL ver: 2023.02.1 (0757)
  • Roon Bridge ver: 1.8 (build 1125)
  • HAT: Pi2AES-Lite
  • Audio HAT: HifiBerry Digi+ Pro
  • Connected to DAC via Coax
  • Connected to router via Wifi 2.4 Ghz Band

DAC info:

  • Denefrips Ares II
  • Connected to Pi2AES-Lite via Coax 1 connection

Roon Core specs/Info

  • Lenovo T480 Laptop
  • core i7-8650
  • 16 GB of RAM
  • Windows 11 Pro
  • Roon Core: 2.0 build 1223
  • Connected to router via 5.0 Ghz Band

Roon Device Setup for RoPieeeXL:

  • DSD Playback strategy : Convert to PCM
  • MQA Capabilities: No MQA Support
  • Volume Control: Fixed Volume
  • Resync Delay: 5000ms
  • Max sample rate (PCM): Up to 48khz
  • Max bits per sample (PCM): 16
  • Zone grouping delay (ms): 0.00
  • Clock master priority: default
  • Enable MQA core decoder : No
  • Force Max volume at playback start: No
  • Buffer Size: Default
  • Multichannel Mixing: Downmix as needed


  • Changed from COAX to Toslink from Pi2AES-Lite to DAC → Same white noise
  • Connected DAC to via USB to another device computer and played through Roon → I heard music at a normal volume
  • I can play to my other devices with Roon in the same room.
  • Changing the Resync delay helped at first, but I haven’t been able to get it to work in a few days.
  • Disabled all filters for the end point is roon

I followed the two instruction guides:

→ Section 7 says that the HifiBerry Digi+ Pro can be used.

Why is core on 2.0 and bridge on 1.8? Maybe that’s the latest version.

That is a great question. According to my core, it says they’re both the latest version.

1 Like

I have it on auto-update, and it’s been on Roon Bridge 1.8 for some time and works fine. I’m using RoPieeeXL and RPi4 with Pi2AES (not Lite).

Have you tried setting RoPieee to use USB output (No HAT configured, and turn on Audio USB), and connect USB from the RPi to your DAC? If that works, the problem may be with the Pi2AES-Lite and you should contact Pi2Design.

How can you have both on the same Pi 3?

There is only one HAT on the pi. Audio HAT is what the driver is called in the RoPieeeXL web page and I wanted to use the same nomenclature:

Not yet, let me try that later tonight and report back. I figured I’d try here first in case there was a simple Roon setting I wasn’t aware of :slight_smile: .

@mSpot, I tried what you said and changed the RoPieee to have no hat configured, turned on USB Audio, and left the HAT physically connected.

I was consistently able to get music to play, but would occasionally get errors about the file loading too slowly, where then Roon would skip to the next track. I would think this is probably due to a transfer rate issue because of the wifi connection, but I won’t have time to move it closer to my router for the next couple of days.

Two other issues could be with my Roon core:

  1. Too far from WIFI → I can try physically connecting it to see if that improves the situation
  2. HDD transfer speeds → This is likely not the case since all the music is on the SSD.