Low Level Crackling - Clock issues?

Just an FYI, I personally didn’t hear any difference using DietPi (Although I didn’t try in my multichannel setup). So don’t feel like Ubuntu won’t provide excellent sound. With tested compatibility for compliant devices, and sampling control etc it seems to be the best option atm (at least with my setup).

Ubuntu server is an image and easy to install. I believe when I installed Roon bridge, I needed to install a few small packages, like: chmod, sudo?, trz, curl, once done Roon bridge installed perfectly.
When you try to install Roon bridge, following the Roon directions, Ubuntu will tell you which processes are failing.

Ubuntu/Roon bridge has been flawless for me. Rock solid, no clicks pops, etc.

1 Like

On a side note, I was going to install Ubuntu and Roon server on the same PC, to see if this also works with the Motu MK5 lite. ATM my NUC Rock loaded PC, exhibits much of the same behaviour as Ropieee.
Which seems to be Kernel related.

Your Ubuntu Server on RPi4 is running which kernel?

Looks line mainline is up to 5.14 now

RoPieee is at 5.10

This is mine atm. Thats post sudo apt-get update

Will be interesting if an update to RoPieee from the current 5.10 @spockfish at some point, gets it work

1 Like

I don’t see how all the XL functions could work, with multi channel?!

As previously mentioned, OP in this thread is only interested in stereo working.

One of the posts you quoted above is about HDMI and multichannel with RoPieee, not related to this particular thread issue

We shouldn’t confuse too many different things in this thread and stick to his issue

1 Like

Sure. Within that thread, questions were asked about USB audio (Albeit Multi ch).
Its all related, stereo or otherwise. Linux compatibility simply comes back to the kernel compatibility and the device supporting USB compliance.

They all say “Class Compliant”

Even Focusrite say that on their FAQ page about Linux

The practical reality is mostly not straightforward

Maybe changing though. Motu seems to have made an effort.

RME walk the walk

We agree.
The most recent kernels (5.11+) seem to solve this issue, or at the very least improve the chances of success. Like I said, the solution is Kernel + USB compliance.

UPDATED… Sorry I have updated a few times, as I observe issues.

OK, So I took the time to install Ubuntu Server 21.04 on a Series 4 i5 laptop.
uname -r = 5.11.0-36-generic
I then installed Roon Server.

All observations are with the Motu Mk5 lite connected to the Roon server via USB:
(Please bear in mind with the Motu directly connected to my RPI4, everything works perfectly)

Test 1: Stereo
When I set the device as 2.0, and downmix, Stereo works, but I get noise on unused channels.
I did experience crackle using my PC’s USB 3 port. Using a USB 2 port everything is fine (Cable?)
Easy enough to mute unused channels down in Cue Mix.

Next I set the Motu as a 7.1 device, channel mapping, procedural mix.
Stereo works, and it seems I get no noise on unused channels, no crackles etc using USB 2.0 port.
USB 3.0 port I have low level crackle (Could be the laptop or cable).

Test 2: Multi channel
I set a procedural mix, set the device to 7.1, channel mapping.
I get 8 channels of audio, and random noise appearing on channels 9-10 as observed on other threads. USB 3.0 I get low level crackles, similar to an old vinyl record.
USB 2.0 port is fine. I wonder if I need a more recent PC, or a new USB cable.
I’m using the OEM Motu one…

This is very odd, as the RPI4 running Ubuntu is perfect, on USB 3, or 2 ports.

I hope this helps everyone.


It does not work. I tried to add something in rooExtend to give Roon the information that there are more than four channels. But my approach failed. I could not make it run without occasional dropouts.
I Sold the Motu M4 and got a RME ADI-2 Pro FS R. It also has a four channel DAC but on the USB side it hast either six or eight channels. I use it with Roon on a Pi4 with rooExtend and the built in Roon Bridge. I run a 2x2 System with it with the crossovers in Roon convolution filters.

1 Like

Perfect, thanks.
I run a Motu MK5 lite, with RPI4/Ubuntu USB, works perfectly to.
Thread is here: Motu UltraLite-mk5

It seems there are certain combinations of setups which Roon just doesn’t like.
I.e. Motu direct to Ubuntu/Roon Server, V’s using a RPI4/Ubuntu endpoint.

In saying this, Win10 works in every combination, with my MOTU running its Asio driver.

Running the Motu at a RAspberry Pi4 you have to use a REAL USB3 cable. The cable shipped with the Motu will not work. USB3 cables have more wires inside. Use this at a USB3 Port of the Pi4 and the interface can be used.

Mine has worked perfectly thus far. No issue into the RPI4/Ubuntu.
But I will grab a different USB cable to try, and better test the USB 3.0 ports on my PC.

Motu supply a USB C to Type A cable.
I would assume this cable would be USB 3.1 compliant.

Excuse my dumb questioning, but you did install Roon Bridge in DietPi software, right?
If so, what did you see, exactly?
no go is a little bit too monosyllabic, although counting two syllables :zipper_mouth_face:

Just trying to understand…

BTW, current DietPi 7.6 kernel version is 5.10.60-v8+ on my RPi3b+

No go refers to the complexity of getting it all up and running on my Pi4b - flashed and inserted the card, but unable to access the Pi subsequently, even though I can see it’s IP address.

I’m an audio engineer but not a software expert and complexity of getting DietPi working is not for me, especially compared to RoPieee, Volumio or VitOS.:slight_smile: :relaxed:

My Pi’s are all run headless - they’re nowhere used to their full potential, I realise that. However I’d prefer to spend time listening to music than fiddling around with software installs - I do enough engineering when at work!!

So I didn’t have time to spend with DietPi last night, but this is not to say it couldn’t work or is deficient in some way, other than not being as plug and play as other offerings.

Sorry for any confusion arising from my initial vagueness and wow! - the number of overnight replies to the thread is amazing: thanks all!! :smile:


I hear you, no worries!
Had just been curious as to where you got stuck in a dead end…
Good luck then!

Out of courtesy and curiosity, I just got round to installing DietPi and then Roon Bridge, via the software search, then install option on the DietPi ‘desktop’.

Still crackling apparent.

Currently trying to install ubuntu on my Pi4 B, but I can’t for the life of me work out how to get the bridge installed afterward.

Right, after much faffing and flashing and ssh’ing, finally got Roon Bridge running on Ubuntu 20.04.3 LTS and the crackle is still there.

Not as bad, it’s almost listenable to now, only kicking in on transients in the music. Played around with the device settings and dropping master clock to low priority helps, as does adding in a bit of buffer.

However, I’ve got the RME as a fallback until I go through it all over again when the M4 arrives, next week.

1 Like