Lumin D2 automatic firmware upgrade

I am still at 11.5, though I have an automatic upgrade turned on in the Lumin app.
I tried to restore the settings once, but it did not help.

What might be the issue here?


Please power cycle the Lumin. Make sure both the Lumin and your iPad are connected to internet via a WiFi router. After Lumin player is booted up, double tap iPad home button, swipe away Lumin app, then relaunch the app. The app should prompt you for upgrade.

I did exactly what you asked and did a factory reset before that.

But it did not work - app still has not asked me to update the firmware.

Please power off the Lumin, iPad and Roon Core. Please set router DNS to Power cycle the router, wait for 5 minutes, then power up everything and retry.

hi Peter.

I tried everything you said, deleted and reinstalled apps as well, but still no effect.

The first time when the new firmware was released, it might have been skipped by me accidentally.
Might this be the issue?


With Lumin app (not Roon), does any of Tidal, Qobuz, Spotify Connect or TuneIn internet radio works?

yes all works great, no other issues

1 Like

Manual firmware upgrade instructions sent to you in PM.

thanks a lot Peter!
all worked out

1 Like