M10v2 Roon uncertified?

Just purchased the Nad 10v2 but roon seems to show up uncertified am I the only one or is this normal?

I believe this is not (yet) certified. Even NAD’s website does not claim it’s “Roon Ready”.

I hope things go more quickly for the NAD then for the Bryston BR-20. Nearly a year now and still not certified Roon Ready. Apparently the new Lumin P1 is already certified, and I don’t think it’s even available yet. I am starting to think I should have bought the Lumin instead of the BR-20.

For me it says Roon ready on the website. And when In the settings of the Nad it shows Roon ready.

There was a firmware update yesterday. Have you updated and does it change anything?

I own the first gen M10 btw. Great device.

As for NAD’s website, I noticed it states “Roon” whereas for the first gen M10 it states “Roon Ready”. Reason I figured gen 2 is awaiting certification.

I am confident @support can shed some light on this.


Yes I am impressed with the device, I selected it over the Cambridge EVO as sound wise it was better but the fact Roon is not working I am thinking about swapping it while I am still in my 30 days purchase time scale.

I don’t see why this won’t be certified like other NAD products are.

@danny would you know anything about this?

1 Like

Hi All,

This device recently passed certification. Can you please re-check Roon to see if you are still getting an error? If you are, please try to reboot your Roon Core and let us know if that resolves it, thanks!

Thanks Noris, that worked I can confirm now Roon is working on the M10 v2.