M3U import not happening

Have exported some M3U (both simple and extended) to a watched folder, but noting appear in roon. The Settings dialog has ‘Watching for new files in realtime’ but no files has been discovered. There are several M3U files in the folder …

Yes – how do we get Roon to see them?

Never mind – you have to quit Roon & re-invoke, prompting the auto-scan, after which the new playlist(s) appear.

I have the same problem. Added the folder with my m3u playlists and it never adds any of the playlists. I have tried exiting and then restarting the roon software but it still doesn’t add the playlists.

Make sure you’re putting them in the root folder; I believe I accidentally put one in an artist folder & Roon didn’t see it. Anyway, check & see if you want.

Not sure what you mean by “root” folder. It’s a folder like all the other watched folders. For example, I have D:/Jazz folder, D:/Rock folder, etc., (all work just fine) and D:/M3U playlists folder. Maybe it takes a while for the indexing to occur??

Just tested in the root folder or in an artist sub-folder. Doesn’t matter, works either way. Auto-prompted re-scan has been very predictable & reliable w/my W7-64 from NAS setup. Just works…

OK what is “auto-prompted rescan”? Is that simply what happens automatically after restart of the program or do you have to perform some action to get that going?

Sorry for the continued questions but it’s not working for me.

by which I mean the spinning circle in the upper-right does its thing within a minute or two of starting Roon; when it stops a minute or so later, any additions or changes to my .m3u files appear in the Playlists view.

Remember, your .m3u files have to be in the same folder you told Roon to “watch.”

In my case, my NAS is M, the share name is Mu, and I have a root folder named M. Within that are the innumerable artist sub-folders. So the path is \M\Mu\M (for Roon to watch). Roon sees .m3u files successfully either in \M\Mu\M, or in \M\Mu\M\xxx…if your .m3u files are inadvertently not in your watched folder, Roon will never see them.

Yes. I have them in the root and scan happens I suppose but they never show up in my playlists. I’ll have to experiment with moving them to other folders and see if they show up. Thanks for your help.

I cannot get this working . I’ve tried to place the files on a share, \server\playlists and put 4 playlists there, but roon does not discover them …

Everything seems ok … I expect the playlists to show up in the playlist view of roon, right ?

Here’s the content of the share :

bwa, based on your screen cap, it looks to me like Musikk and playlists are two separate root folders on the computer server3. Try copy/paste your playlists folder into \server3\Musikk, then exit/re-enter Roon.

Yes, that worked, but it makes no sense … It should have been discovered anyway when it was in the root of \server3\playlists. A watched folder with playlists in it, should be imported anyway …


I have the same problem - my playlists are in their own separate (watched) folder because other applications use the playlists too : I want to maintain a separate playlist directory “away” from my music files.
Why doesn’t this work ? Makes no sense…

As a new user, I find this very annoying. I have multiple root folders because of my library size and configuration. I should be able to have a seperate playlist watched folder, however nothing gets imported unless I place the playst inside one of the watched folders. However, this leaves out all the track from the other watched folders.

1 Like

+1 for this

This appears to be a longstanding unresolved issue. I have many m3u files that never get imported. Seems there is little rhyme or reason why some work and others don’t.

Try restarting your client and scan storage again…sometimes they show up.

Thanks Larry: I think the issue is that the m3U files are pointing to music in Tidal. Let’s see what the folks at Roon say.