Mac Mini Core to ROCK on Intel NUC10 i7H - experiences of non-expert installer

Morning campers,
After much worry I have finally taken the leap. I thought I would let other ditherers know how it went.

  1. An Intel NUC 10 at a reasonable price is not so easy to find. I bought a second-hand 2020 version. The seller had updated the BIOS, which was lovely.
  2. Added components, I went with a 128GB Gigabyte NVMe M.2 2280. Memory Corsair DDR4 SODIMM 2400MHz 8GB, second SSD Samsung 870QVO 1TB.
  3. BIOS changes were more complicated than I expected. I think the seller had installed the windows intended UEFI BIOS FNCML.0053.EBU.exe, but I managed to get through the options and get legacy BIOS to work.
  4. Installation of ROCK, via 16GB pen drive. Wrote with Etcher. It seemed to work in seconds. I was a bit confused as no desktop except the IP address. Used windows computer to access, and then copied the codec file to the data directory. Format large SSD.
  5. Backup database… not so easy. I struggled with networked Kubuntu box, small pen drive, so used an old 160GB Hitachi 2.5 inch hdd in a caddy and that worked fine. The network share never got passed “transferring”. The hdd got to “transferring 10%” etc quite quickly… New caddy required for the hitachi… Updated the database to ROCK. Works quickly, but the odd change needed, but nothing too complicated. (mainly the audio players)
  6. Copying music files. Took a while, but if you plug a previous data hdd into the ROCK, access to the ROCK data directories gives you access to the new internal storage and the previous data hdd allowing easy comparison of the collection and update of any anomalies. The copying process flagged up some M4a files that won’t run on ROCK. Any such files need converting to alac or similar. The ROCK via the Roon desktop also showed up some crappy tagged files which was nice.
  7. It’s fast. One issue with android phone not behaving. I turned it off and on again. Obviously all players need connecting to the new core.
  8. Anyone having BIOS problems I’m more than happy to explain my settings.
  9. Good luck and don’t worry, nothing you do should be destructive.

Congrats. Thanks for sharing your experience.

I had been running Roon Server on Windows 10 Pro for several years. The computer was a 7th gen i5 NUC that happened to be compatible with ROCK, but I was using it for other things too, so having Windows was handy.

Not long ago, I decided to transfer all of those non-Roon activities to a newer computer. I then deactivated my Windows 10 Pro license and installed Roon OS on the NUC. I’m now kicking myself for not doing this sooner. Roon is so much snappier on Roon OS than it was with Windows 10 Pro on the same hardware.

If you’ve been putting off upgrading to ROCK / Roon OS, stop doing that. In my experience, it’s totally worth it. :slight_smile:


@Michael_Redman, I have a NUC10 that I’m about to return because I haven’t been able to enable Legacy Boot, so any help would be appreciated.

1 Like

It totally works. Let me find the link…here:

Right. I’ve done everything they discuss in there but Legacy Boot is still grayed out.

PM me tomorrow. Happy to jump on a Zoom session to see if we can figure this out.


Here’s what I’ve just done with my machine.

  1. Bios FNCML357.0053.2021.0707.1420
  2. Connect keyboard, and monitor.
  3. Reboot (ctrl+alt+delete or use the desktop off button)
  4. F2 into UEFI BIOS. F9 to get back to default, F10 and save.
    5.F2, Boot>secure boot mode>disabled. F10 save and boot F2 again.
    6.Onboard devices > HD disabled to stop HDMI NUC outlets annoying me. (Optional) F10 save and F2.
  5. Power>secondary power settings> sleep type support>legacy S3 Standby F10 save and reboot F2
  6. Boot > legacy boot enable and UEFI disable (tick boxes) (although I forgot to disable the UEFI option and it still worked. F10 save and reboot, F2
  7. Boot, to enable number one as your fast M.2 drive and the others don’t matter, but no uefi ethernet stuff if it appears. F10 and save. (Note: the installed drives didn’t appear in the boot drive options until later in the game! Possibly the “enable legacy boot” is the key step.)
  8. You should be good to go.

WARNING : I am not an expert as stated above and I accept no blame for any problems encountered.

PS I’m guessing you didn’t F10 and save enough as you go along, but I may be wrong!

Paul I helped Raz get his working in this thread. It was a while ago and I remember being annoyed that they had made it so difficult
I think it is in this thread.

Edit: Saying that I think Michael has just pointed you in the direction.

1 Like

I encountered ZERO issues while enabling Legacy Boot in my NUC 10i7FNHN1 (2021 build). I followed the steeps pointed by @David_Snyder and @Michael_Harris and all went smooth. Mine came with the latest BIOS loaded already.


I’ve follow your instructions exactly up through enabling legacy boot and disabling UEFI. Those options are grayed out in the Boot screen

Hi, Did you save the new settings between each step?


Do you think it makes a difference that the NUC came with Windows installed?

I wonder.

The bios alterations should be possible before you install your M.2 main drive. New ones with no OS are ridiculously cheap in any case. I’d keep the windows disc as it has a valuable license attached to it. You only need a tiny M.2 drive and you can get one for $25 or £25

At this point, it seems easier to return the NUC and try again later.

Ok, good luck.