Mac Mini HDMI Audio-Out WOL

Hi, I’m using the HDMI-Output of my Mac Mini to connect to a Yamaha AV-receiver. Now that works well until the Mac (or the connected TV) goes to sleep after the music has stopped. At this point OS X (Yosemite) seems to disable the HDMI port. Once I click the mouse on the Mac Mini or connect to it via Screen Sharing (even with the TV off) the music starts playing and everything is back to normal. That means however, that I always have to take some action before I can start playback using roon on another machine (say a MacBookPro or an iPad) which kind of defeats the purpose. Admittedly the Apple iOS iTunes Remote App has the same issue - but it’d be really cool it roon would somehow solve this problem by waking the display server or something.

Apparently nobody has this issue or this setup. But I’ve just noticed another issue which is a deal breaker. Don’t know if there has been a silent minor update or why this behaviour only cropped up yesterday but here goes:

My setup is
Mac Mini 2.4 GHz (Mid 2010) -> HDMI -> Yamaha AV-Receiver -> Samsung HD TV
(well there are 5 large speakers attached to the receiver, of course)

I’m using exclusive mode since I’ve got a lot of Hi-Res files

The issue:
roon attaches itself to an output. The HDMI-output device changes its name depending on whether the TV is on or not. Now I don’t know what roon is doing but when roon is running any change (switching the Yamaha and/or Samsung on/off) will result in the HDMI-output’s disappearance from the system until I restart the Mac Mini. As a workaround I could start/stop roon before switching the other device on/off, but the app takes about 10-15mins on that machine after launch until it’s completely usable, so that’s not an option.

Any idea on how this issue could be fixed?

Does this only occur when exclusive mode is enabled?

HDMI is notorious for introducing Jitter into the Data stream…which is bad for Sound Quality

Why not use the SPDIF Optical Out of the Macmini into the Yamaha…and avoid these HDMI glitches

Even better would be a Async USB device to Optical or Coax into your Yamaha…or Async USB DAC into the Yamaha via Analog in

It happened with exclusive mode enabled.

When trying to reproduce the issue with different settings everything worked fine, of course. Weird. I’ve had output disappear two times yesterday and this morning so I know it does occur. Will disable exclusive mode and see what happens tomorrow morning.

I’m using HDMI since SPDIF doesn’t support uncompressed multi-channel output. Neither does roon at this time, but I’ve only just rediscovered MCH so I’m not willing to give that up. All that jitter be damned. :sunny:
I’ve considered buying an external MCH interface but then again AV-receivers have digital processing for room-eq adjustments and I cannot quite imagine the HDMI-jitter being worse than the effects of multiple DA-AD conversions. However, I digress. Thanks for your suggestions and I might try SPDIF as a temporary solution. Hadn’t thought of that.

As you say, Roon doesn’t do Multi-channel sound at the moment…so while that is the case, why not connect an Optical cable from the Mac to the Yamaha

And set the Roon app to use that connection in Exclusive mode

You can then use the other Player app over HDMI to the Yamaha, to achieve the Mch replay that you’re currently using

i.e. Roon + Optical [exclusive mode] for Stereo Replay…and other Player + HDMI for Mch replay??