macOS Roon Remote audio sources intermittently disappear when on different subnet

Roon Core Machine

Roon ROCK running Version 1.0 (build 227) stable
Roon Server running Version 1.8 (build 814) stable

Networking Gear & Setup Details

I use Ubiquiti Unifi gear for routing and switching. The ROCK and all my other IoT devices are on a separate subnet from my primary remote, which is my macOS laptop.

Previously, my macOS laptop was my first Core before I restored its backup to the ROCK on my Intel NUC.

Network topology

I have two networks:

192.168.X.0/24 ------- laptop
    Unifi UDM Pro (firewall)
192.168.Y.0/24 --+---- Roon ROCK
                 +---- SONOS speakers, etc.

The ROCK and my SONOS speakers are on the Y network. My macOS laptop is connected to the X network.

I have an explicit rule that allows all traffic from the ROCK to reach any address in the X network.

Connected Audio Devices

My remote macOS 11.5 laptop (a 16" MacBook Pro) is connected to an RME ADI-2 DAC via USB.

Library Size

~5,000 tracks

Description of Issue

When I’m away from my computer for some time and it locks, requiring me to wake it up again, or when I restart Roon, I lose all of my Mac’s audio devices when I go to Settings > Audio or try to select a source. So I can’t play music using Roon on my primary computer any more.

Previously, I was able to work around this issue by deleting or renaming ~/Library/RAATServer, logging out of my Core, and logging back in again. I’ve also tried rebooting my Core, rebooting my Core, to no avail.

When my audio sources appear again, when I attempt to enable the ADI-2 DAC, it prompts me to name it. As soon as I press enter or click outside the name field after naming it, Roon Remote crashes.

Note that it’s not just the ADI-2 that disappears – all of my Mac’s outputs disappear and there isn’t even a “This Mac” section in Settings > Audio.

These defects appeared when I relocated my Roon Core, running ROCK, to the IoT subnet. After I did that, I had to set up a firewall rule that allows all traffic from my ROCK to my laptop, and things started working again - or so I thought.

I have mDNS broadcast enabled, and my Roon Remote is able to see my SONOS speakers which live in the IoT subnet.

My laptop is usually connected to both wired Ethernet as well as wirelessly, so I have disabled wireless to try to rule that out.

Not official support, but, just wanted to note, that would be the expected behaviour if your MAC client cannot reach the Core. The Roon client receives the audio sources list from the RoonCore, not the local machine.

I should add that I see other sources, such as my SONOS speakers, in the Settings > Audio list, in addition to the various HDMI outputs that are part of my Intel NUC ROCK. So it seems that I’m at least able to get a sources list from the ROCK, but the ROCK isn’t recognizing that my macOS remote exists?

Exactly, the Core, in essence, queries the MAC asking “hey what audio sources do yo have and what do they do”, if it doesn’t get a response then it doesn’t display any devices in the client. Remember, for most things, the Roon client is showing things from teh perspective of the Core, not, the local machine.

And, given the bifracated nature of your network setup, I would bet that is involved in the issue. If you moved the laptop to the other side with the Rock and Sonos, do the devices appear?

That’s the thing… it is an intermittent issue that is resolved by some combination of:

  • Rebooting the Core
  • Logging in/out of Roon on the Remote
  • Restarting the Remote
  • Deleting or renaming ~/Library/RAATServer

At present it’s working, so I don’t have a way to test until it fails again.

However, I have tried joining the IoT network via a wireless connection and that hasn’t been a reliable way to get the Mac showing up in the audio sources list, unfortunately. The next time I see the issue, I will try joining the wireless IoT network and disconnecting the wired connection before refreshing the audio device list.

That all said, it seems to me that this intermittent failure shouldn’t be happening - if it’s working now, when my Mac is connected to a static IP address in my “X” network, and the Roon ROCK can certainly stream music from the “Y” network to my laptop, then there should be no network reason the Core decides my Mac is no longer available/reachable.

I’ve confirmed that Roon works as expected when I’m only connected via wireless to my IoT subnet.

I can prove that my Roon Core can reliably connect from its IoT subnet to my primary subnet, however, because my music library lives on a Synology NAS that’s not inside the IoT subnet. In other words, the Core can and does consistently exchange network traffic outside its subnet.

I’d love a response from the Roon technical team @support on additional troubleshooting tips I can try. As far as my firewall logs are concerned, it’s not dropping a single packet from the Roon Core. I have a hunch that moving the Roon Core between subnets is at the root of this issue and if I reinstalled a fresh Core in the IoT subnet, things might just work (at the loss of my database).

Any help greatly appreciated!

Hi @Matt_Gray ,

Welcome to the forum and thanks for reaching out!

Unfortunately, Roon does not support usage across VLANs or subnets, so that may indeed be the reason why you are running into this behavior, please see our Networking Best Practices Guide for further information regarding this.

Some other users have gotten this to work, but this falls in the #tinkering category, so I have moved your post over here.

You may wish to look over this thread for further suggestions on what other Roon users did to get this operational: