Mapping a Synology Network Drive

(Robert Hay) #1

Hi Everyone…

Despite having followed the instructions, I’m having trouble getting my Roon Core (Running on a Late 2015 27 iMac) to map my main music folder which is on my Synology DS1515+ NAS.

I’ve entered all the correct path details to the shared folder…

smb://NASNAME/volume1/Shared music

When doing this, I get an…

“Could not connect to share: Unauthorised” message…

so thinking I’m getting close I add the admin login for the NAS and then Roon returns the message…

“Invalid network path specified”

So I try with removing the share name and adding the actual IP address…no luck…I try creating a specific user profile in DSM for Roon…just incase multiple logins with the same credentials are the issue…again no luck…

Has anyone hit this problem?

Cheers

Rob

#2

@Robert_Hay2 Your share should be smb://NASNAME/Shared music
Ensure any names are correct including capital letters.
No need for the volume1

1 Like
#3

HI Rob,

You aren’t alone. I had exactly this problem when I installed Roon Rock on my NUC yesterday and attempted to connect to the ‘Music’ share on my Synology DS216+II NAS.

I simply couldn’t get it to connect using the Host name in the path, but I did get it to connect successfully by specifying the IP Address in the path. Are you sure you used the correct IP Address?

(David Orgel) #4

The other suggestions may have helped you out of your jam, but just as a tip to others, on macOS, if you mount the NAS volume in question on your desktop, select the volume in the Finder, and hit cmd-I, it’ll give you the correct path (less any login info needed).

(Mr Fix It ) #6

@Robert_Hay2 You need to use SMB to mount if you copy the Mac mounted format…AFP will not work.

You should also try to make sure your NAS uses a fixed/reserved IP address so it won’t change anytime if you use the IP address (recommended)

smb://192.168.0.2/music should work with synology and the default music share name. case sensitive and substitute your own address and user name password as needed - multiple logins are fine…but a dedicated Roon one is good too

(Robert Hay) #7

Hi Guys,

Thanks so much for the support, sorry it’s been a while in replying, work had me away from home for a week or so.

But I’ve had the chance to work through all the suggestions…and good news I’ve mapped the NAS now…

I ended up using the IP address, and actually had to revert to the admin login I set up for the NAS rather than the iMac specific one…who knows why…but library is being scanned away.

A good start to the week.

Thanks again.

Rob

(Paul Lane) #8

Hi Robert

I am having similar problems with my new Synology NAS. Can you explain what you mean by the “admin login rather than the iMac specific one”? Is that a login on the NAS? I have tried changing my user on the NAS to have heaps of permissions and even no password but still getting “Unauthorised” messages when I try to add a network share in Roon.

(Robert Hay) #9

Hi Paul

Re-Reading what I wrote made me realise it doesn’t make a huge amount of sense, sorry…

What I’d done was to create a separate user account on the Synology for each piece of hardware, just in-case there was an issue with multiple sessions using one login. I stumbled upon this problem a few years ago when setting up a NAD M50 to share a NAS with other devices, the M50 wasn’t UPNP/DLNA, so just needed the drives mapped to be able to see their content, and I’d already had another computer logged in using the main admin identity and password.

I was advised by one of the guys at NAD that I should create a separate user ID on the NAS to avoid any problems with the Synology OS, in that instance, it worked perfectly and I have adopted that approach with other devices on my network.

But having said all that, I ended up using my admin log on to the NAS for Roon, and that seemed to be fine.

I’ve now bought a NUC and installed ROCK, so not using my iMac as the Core anymore…and wow what a difference in performance, both in speed and audio, can’t quite get over it…just using an AudioQuest DragonFly Red as the output.

Best

Rob

(Paul Lane) #10

Robert

Many, many thanks. I have responded elsewhere to others who offered help but your mention of using the “admin” username was the final piece in the puzzle for me. I enabled it, set a password and having used a fixed IP address rather than a share name (NAS) it finally worked. Days of frustration are at an end.

Paul

(Hugo) #11

I’m at a loss here. Feel like i’ve tried every combo possible but no luck adding a network share betwen synology DS118 and innuos zenith II. Tried admin login, static ip, smb, etc. Any thoughts?

(Hugo) #12

Got it!. Had to use the smb path given under File Services in Synology control panel. Then add to the end of it the top level Share Folder. So file path of smb://DS218/Roon218 and then user login details (not admin). This on a mac.