Meridian endpoint and static IP addresses

@brian @danny You guys have experience with Meridian gear, I hope you can help me.
I have wiring constraints in my house, came up with a clever idea, but I have trouble getting it to work.
The internet comes into the house and connects to a fast wifi router, and I have one MS600 hardwired in the living room over there. In the music room in the other end of the house I can’t get wiring. So I installed a NUC (2 TB SSD, don’t even need wiring to the NAS) and an MS600, just the two of them on a switch. The NUC is also on the wifi network so I can download content, and get Tidal.

But if that short network is by itself, the NUC doesn’t discover the MS600. If I temporarily wire the music room network to the main network, discovery is ok; then I can disconnect the temporary wire and the NUC can play to the MS600 without problems. So I figure it is because the isolated network doesn’t have DHCP. So I set up static IP addresses for the MS600 and the NIC of the NUC (the NUC’s wifi adapter is still DHCP). But I can’t get it to work. They still don’t discover. Experimentation is tiresome because of frequent reboots…

What do you know about Meridian discovery and static IP addresses? Can I do this? Or do I need to do wiring?

I believe that this configuration should work.

I think you might be having a routing problem. If you haven’t tried this already, try putting the wired/static network on a different subnet than wireless.

So maybe wireless is 192.168.1.x/ and wired is 192.168.2.x/

Thanks, @brian. That’s what I thought, and I think I did that, but I may have made mistakes. Lots of reboots, very frustrating.

I’ll go back and check.

is there anyway you can test to see if the both devices are on the network? i.e use a third device and ping the other two? Do you know about ARP ? Could the D H C P address be cached?

@gmt I’m sure I can. I’ll do some more systematic testing.
Although I have weak tools at home.
Don’t know about ARP. Is it something I should get hold of?

More info on ARP ARP details

it effectively matches the mac address (a unique address for each network device) to an IP address (and remembers it by storing it in ARP cache) . I’m not saying this is the issue, but it may be possible that your cache has the DHCP address stored against your MS2000.

At the NUC, go to the command prompt (dos window) and type arp -a to get a view of your arp cache. arp * d clears the cache (this will not harm anything)


@brian @gmt Thanks for your suggestions.
Everything seems to work except Roon discovery. I set up the wired network as 1.x and the wireless remains at 0.x .
From the NUC, I can ping the MS600, I can browse to it and confirm its MAC and IP address.
I checked arp, shows the correct addresses. Clear arp’s cache and check again, still correct.
But roonserver doesn’t see it.

I then tested the configuration that works with DHCP, plugging in a wire to the router into the switch. Rebooted. Everything else works, but Roon still can’t discover the MS600.

Annoying, this would be a very elegant solution. There are other ways to solve it here, but I really like this simple configuration – if only it worked.

One question: when setting up the static IP address, I need to specify a gateway for the wired network. But I don’t have one, with only those devices on it. I specified the standard gateway on the wifi network, Could this be misleading Roon?

The wired network shouldn’t have a gateway. Try or blank for the gateway on both the windows and ms600 sides of the wired network. I’m not certain that that’s your problem, but it’s worth addressing.

Another thing worth checking/modulating are any firewall settings on the windows side of that ethernet port. If anything’s turned on, I recommend turning it off.

I’m going to play around here and see if I can replicate the problem.

…Ok I played, and I got it working. My wireless network is 192.168.1.x, so I used 192.168.10.x for the wired network.

This is what my configurations look like. I ran an ethernet cable direct from the windows machine to the MS200–no switch (not that it should matter):

Windows machine (8.1):


And it shows up in Roon:

Maybe something on one of these screens looks different from yours?

Thank you, I will check when I get back home.
Could have sworn I tried it with no gateway and everything hung up completely,
but I may be wrong. We’ll see.

@brian yep, it works. Turns out it was the firewall, as so often. Should have checked it up front… Turns out there were three entries for Roon.exe and two for roonappliance.exe, with random settings for private AMD public network. Turned them all on, and it works. Thanks a lot. This is a really neat solution.

And in the meantime the 818v3 arrived, also works. Woo hoo!

This topic was automatically closed after 4 hours. New replies are no longer allowed.