Metadata issue with Album artists showing up as Various Artists

I just downloaded a single track from QoBuz onto my NAS. The name of the song is “I’ll Remember” by Madonnna. (Dont laugh!! She has an amazing talent writing songs and a beautiful voice. Watch Evita!)
On my Ipad The “Album Artist” is showing up as Various Artists. I would like this track to show up under Album Artist Madonna. It is the soundtrack to a movie “With Honors” so that’s probably why it shows up under Various Artists but I would like it show up under Madonna. madonna was born for the soundtrack to the musical Evita. Get out the popcorn and watch it.

Nothing wrong with a little Madonna. :wink:
You can manually edit the artist info. It is more than likely getting the VA setting because as you noted it’s a sound track.
At the album click the . . .
select the edit album heading.
+ Add Primary artist
you should then be able to remove the Various Artist tag.

Thanks Paul.That sort of worked…
However using my Ipad and going to My Library / Tracks it still displays Various artists.
I’d like it to display Madonna.

Have you forced a rescan of your library to pick up the changes?
settings →
storage →
your path, click the . . . then force rescan.

I think that will pick up your changes?
If not. I will be learning with you.

Nope that didnt work. When I look at “My Artists” I see Madonna and when I click on her it takes me to “My Library” where I see the track. When I bring up the Album “With Honors” it says Various Artists and underneath that it says Madonna. However when I bring up “My Tracks” it still says Various Artists
in the “Album Artists” column? I would like it to say Madonna in this column.

Did you look at all the artist data on that page and remove all VA mentions?
I’m assuming yes, but verifying.
If so. I do not have a better answer. I’ll be watching to find out.

This worked!!!

In the “Album Editor”. / In the Album Artist section / clicked on Edit and entered Madonna.

Now when I go into “My Tracks” the “Album Artist” column says Madonna.

Thanks for the help!

1 Like