MicroRendu not recognizing Chord Hugo DAC after powering off/on

I switch off my DAC (chord Hugo) after use. The uRendu does not have a power button so I assume it is to be left powered on. The issue is that next time I power on my DAC the rendu does not recognize it and hence my endpoint does not appear in Roon.

I suppose I could login to soniorbiter.com and reboot the rendu before every listening session (is that how people do this?) however the reboot function does not seem to work. I therefore need to pull the power to the rendu and restart it with every listening session. I am running v2.3.

Am I missing something? Is this safe for the rendu? Thanks.

Some DACs behave this way…most don’t though. We can look into the restart issues if you send the unit in as part of the 1.4 hardware update.

Hi Jesus. I am not planning to send my unit for a 1.4 update, so that won’t work unfortunately.

Is there a plan to make the Chord Hugo recognisable by the uRendu once it is powered up (so it behaves like “most” DACs)? I would expect this to work on all versions of the soniorbiter software (v1.0-v2.5) as this is clearly a bug in the core functionality of the device. The restart-via-software workaround is not a very elegant solution (were it to be a working one). Also, my family who use the system wouldn’t be able to do this… it is messy.

The 3 components here (Hugo/uRendu/Roon) are all computeraudiophile products of the year, there must be many people using this very combination.

It is working with my dragonfly red, but not chord hugo.

After plugging in the dragonfly a few times, I then tried the chord hugo’s USB cable while it was powered on, and that worked also. I then tried switching on/off the hugo while plugged into the microrendu and low and behold it started appearing. This was definitely not working over the last few days and earlier today. As long as this keeps up I am happy…

Hi, i am using the Lab 12 DAC 1. It has been playing fine with microrendu, but for the last week it will not recognise the DAC. I have tried every thing. I put the printer cable into the dac and it worked through the PC. Plugged the Rendu back in and nothing, it just will no longer recognise the DAC. I fear the problem is with the Microrendu. Please any suggestion will be appreciated. many thanks.

Hugo, Hugo TT, and Hugo TT2 are all supported devices. Please inspect the USB connector for damage.

Try this in order:

  1. Remove the power cable from the Rendu and the DAC.
  2. Connect the power cable to the DAC and power it on.
  3. Connect the power cable to the Rendu.
  4. Go to Apps / DAC Diagnostics and confirm the DAC is present.
  5. Go to Settings / Roon Ready and press Save.
  6. Go to Roon / Settings / Audio and enable the Rendu.