MOCK - Tell us what strange gear you've installed ROCK on!

You get cd ripping with ROCK to. I was using Vortexbox for Roon for a few years as I had switched from LMS and used it as my server for that prior. I decided to go ROCK on the same system but still kept Vortexbox for automatic ripping running in a VM on my NAS. Since they added this to RoonOS I ditched Vortexbox completely and use ROCK for everything. Yes I have the add metadata for use not in Roon but I am not ripping hundreds of CD any more.

1 Like

So an update on this one as I haven’t posted in this thread since I tried the last bit of kit.

I’m using an HP 620 G3 as my ROCK host at the moment. This works flawlessly in every way, but then that’s probably because its spec (chipset, ram, drive layout etc) are identical to an official NUC.

The only difference being my I3 is a 7130U rather than a 7100U so it has a tiny little bit more horsepower.

Spec is:

-I3 7130U
-8GB DDR4 2133
-256gb M.2. PCIe SSD
-2TB External USB

Runs like a charm, doesn’t bat an eyelid when running DSP to two zones and is very compact.

HP actually sell a dedicated add-on module with a CD drive inside it, that bolts to the bottom of the chassis. Meaning you have an all in one mini PC that actually incorporates a CD drive. So I have this connected for ripping via ROCK as well.

All in pretty perfect.

My only criticism, is that in the listening room, with very quiet music, you can just about make out the fan whirring. When I move home, i’ll shove the HP into another room, and use a little HP thin client as an end point (fanless device).

1 Like

Have you got an Apple Watch as well hint hint wink wink?

1 Like

Not very strange, but I have installed ROCK on my SonicTransporter i5 (bought about 3 years ago). I was having issues with STi5 not booting. Attaching a monitor I saw all sorts of errors. Rather than send back to Small Green Computer, I simply installed ROCK on it. (I only used the STi5 for Roon, not the other programs it also allowed.) I ignored the “BIOS” instructions, installed ROCK and copied the CODEC file and everything went well. STi5 connected via ethernet.

p.s. I restored a roon backup (1.7) and all was picked up OK in terms of my library, except Roon reanalyzed all my files.

Running Roon on my old IBM3650 M3 which is also running my Plex server under Linux. Cost me £200 with 2x3GHz hex core Xeon X5675’s and with the graphics card and RAID expansion to expand to 16 drives cost me less than £400.


1 Like

Using ROCK on some machines can be a challenge, hence this thread.
Machines running Roon aren’t really MOCKs. :slightly_smiling_face:

I had the almost the same machine. It drank electricity, mostly because of the fans.

Problem is Xeons aren’t the best processors for Roon.

Hi Slim,

It’s not a problem re power - it runs my Plex server and I can remotely switch it off and on via the management interface.

Not looking at running anything I can help under Windows - I feel more in control of Linux rather than Windows.

I really hope that Roon isn’t doing any audio conversion for me… Although I am very new to Roon!

Thanks for the reply,


1 Like

When playing a track you can look at your signal path by clicking on the light next to the track title at the bottom of the display.

Mr Fix it’s post inspired me to try this since I have a 2012 server lying around, as well. It worked exactly as he said. Fast and easy. On a whim, I decided to take it a step further. I took the hard drive loaded with ROCK out of the server and put it into an older 2010 2.4Ghz Mac Mini. It worked instantly. Loaded up into ROCK without using the option key.

Because it is such an old slow machine, I wanted to find its processing limits. I have to tell you though, I couldn’t find them. This thing handled every DSP option I could throw at it without a single hiccup. It was processing better than my other Roon servers (quad core 2012 Mac Mini and my 12 core Mac Pro). Clearly the “optimized” in ROCK is no joke. They let this thing off the chain. It is literally the only machine running Roon server in my house that can play DSD256 to my Chord Mojo without a single stutter. For the time being, it has become my primary machine and it was only $100 on ebay.

I raise my glass to you Roon, this ROCK thing is very good at its intended purpose even on an unintended machine.


@Papi_Chulo I have a couple of old 2010 servers might give this a go too…Im guessing if the only drive in the Macmin is Rock it will boot up without the option - My mini 2012 server has 2 SSD 256GB drives in it.

Did you need the external USB-Ethernet or did you manage on the built in NIC? Assume you are still on the 2010 unit.


It did have only one drive in it at the time. I was going to try having Mac OS on the other drive and, once booted into MacOS, select the other drive for boot. Then I would wipe the MacOS drive for music storage. We’ll see if any of that goes as planned.

I did use the USB-ethernet dongle because, as you said, I could get nothing else to work. Perhaps if I download some bootcamp drivers I might be able to get them into the ROCK system.

Still using the 2010 Mac Mini to see if it continues its error-free status.

So none of the above shenanigans were necessary for getting a cold boot into Roon. I put a 2tb spinning disc into the 2010 Mac Mini and it started right up into ROCK and had the new disc ready for formatting on the Web UI.

I did find one problem with using this old computer, however. If I have the DSP fully loaded with tasks, there is a 4-5 second delay in executing a new command. This completely resolves when I remove DSD upsampling. Despite this, there is never any problem with playback. It is always pristine. Seems to trade UI responsiveness for flawless playback. I appreciate that prioritization.

1 Like

I meant if one of the drives has an OS X or macOS already bootable installed. I tried to install rock of usb stick with one of my 2010 mm server macs and it wouldn’t see the bootable usb to run the install. Maybe one day I will tear out the drive and install it on my 2012 i7 but as already run an i7 Nuc probably not much incentive.

I thought the 2010 would be out of puff with dsd…I use dsd as a stress test but find it’s not as clear as native bitrates oN most of my DAC’s

1 Like



Okay, here’s an attempt to find the sweetspot between performance and power consumption.

Housed in a Streacom FC5 Alpha chassi is an Asus ROG B360-I Gaming mini ITX motherboard. The processor is an Intel Core i3 8100 which is a quad core/single thread cpu running at 3.6Ghz. The memory modules are Hypex 2666Mhz DDR4, but at this time i can only run one (8Gb) due to the connectors on the NanoPSU… I am awaiting a couple more of those, and then i will resolder the connector “outwards” instead. Not showing is a Samsung EVO 970 NVMe m.2 startup disk.

Unfortunately i can’t seem to land ROCK on the NVMe? I do have ROCK on an SSD atm but since i’m not finished just yet with it i am running Win 10 on it to easily monitor temps and use it for some file management also. (Why on earth is it so much easier to remote a headless Windows machine with Remote Desktop, than it is to remote a headless Mac, from an iPad???)

Finished today is the hard drive rails with rubber bushings for mounting the WD Red 6Tb media drive:

Bought some L-profile aluminium from Bauhaus and some rubber grommets and hard drive bolts from eBay. Works perfectly, cannot hear the hard drive when started up!

Temps stay around 28°C-35°C in normal playback mode, no DSP. When analysing and adding my 150K track library simultaneously as upsampling some RedBook to DSD512 temps tis to about 70°C.

It works excellent as a Roon Core/Server, much quicker than my NUC8i3 running ROCK (with 4Tb internal SSD). And power consumption stays at around 15W when Analyze is done. (Pulls around 60W when running full throttle, analysing, adding and upsampling)

I will go back to ROCK later, but for now i will settle for Windooze!

Oh! I forgot to say, the psu is a 12V 5A brick originally used for my Bluesound Vault. That will be replaced by an external linear PSU also, but this works just fine!


Are you still running this board? I have one and am considering MOCK-ing it. Has ROCK been updated to work with the Intel Ethernet chipset? I ask because it’s been 2 years.

I am using it, yes. The Ethernet started to work when Roon were alerted to that chipset needing drivers for the eighth gen NUC.


Hi there,

Do you have an install guide for pc’s that are NOT intel nucs. I created a boot disk as per the instructions on the following link, but it does not work…

I reviewed the section on bios update, but my pc is an office pc not a nuc. Asus motherboard older but updated bios.

Do you have instructions for trying to install ROCK on a regular pc?

Thanks for your help

Rock is designed specifically for the Intel NUC so there are no instructions from Roonlabs for installing it on a standard pc, you could install Windows and then download the appropriate version of Roon.
Some people have managed to get Rock running on a pc, try searching the forum for Mock.