Mount ROCK internal disk on QNAP NAS

Newbie question so apologies if obviouse.

I’m setting up a Roon Rock (BOXNUC7I5BNH) with an internal disk to hold music.

I can see the ROCK’s internal disk from Windows and map it as a network drive:-


I’d like to be able to mount this drive on my QNAP NAS (TS 253 Pro, QTS so that I can include it within my normal backup process. I believe that @simon_arnold may have done something similar.

I’m using Qnap FileStation5 to creat the remote mount and starting by selecting CIFS/SMB

I then enter the Rock SMB details

Which is always followed by


I’ve tried most of the obvious connection variations such as with and without guest account details, data folder with, without forward and backward slash and I just can’t get it to connect.

Has anyone managed to do this and would they be prepared to shred their settings?

Is there something on either the Rock or the Qnap that I need to enable?

Many thanks.

You seem to use the moniker Guest for guest access.
You should be able to check the box Anonymous login and just connect. Everything else looks correct.

You do need guest as user and password or it won’t connect on mine at all.

Also you need to set it up under remote jobs and create sync jobs in hybrid backup sync if you using it to back it up you cant backup it up from the remote host otherwise.


1 Like

Thank you to you both for replying.

In the intervening time, I managed to get the QNAP hybrid sync app to sync to the rock share. This is the opposite of what I’d like!!

I think this does, however, confirm that the connection details I’m entering to remote mount rock are probably OK. And that the rock cifs/smb mount is functional?


When you remount mount your rock from within File Station does the Retrieve folder list option work?

It doesn’t work for me and I’m wondering if this tells me something.

Mant thanks again.


Did not look at Simons reply closely enough when I first read it!

If I choose active sync rather than oneway sync I can use the existing hybrid sync mount to sync in the direction I want :grinning: Promise to read more closely next time.

I’m still flummoxed as to why the remote mount in file station does not work, but as I no longer need it, I’ll stop worrying.

Many thanks.

You cant back up from the remote connections in file station. They just don’t allow it in the os it’s documented somewhere. Glad you worked it out. It works well I find and I also use hybrid backup sync to backup the same files to the cloud at a later time.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.