MQA blinking on off and clicking noise / glitches

Core Machine (Operating system/System info/Roon build number)

Mac Mini late 2012 i7 / Ubuntu 20.04.1 LTS (GNU/Linux 5.4.0-54-generic x86_64) / Roon Core 1.7 build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Zyxel Unmanaged switches 100Base-TX - Zyxel AM3100-B0 fiber router with 1Gb ISP connection.
Not using WiFi for Roon and video streaming

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node 2i connected with S/PDIF to Hegel H390 with MQA external DAC enabled, tested Audio clock trim.
Ropieee RPi 2 connected with USB to Hegel H390

Description Of Issue

First, i have to say that i do not have a network problem of any sort, so can rule that out (and i am very sure).
Second, am i not sure this is a Roon issue, it probably isn’t.
Third, did not switch outputs on the Bluesound Node 2i (will do that later because it is a hassle)

Chain of events:

  • using Roon, all joy.
  • sold my old speakers, and did not have new ones.
  • moved core from Mac OSX to Ubuntu 20.04.1 LTS on the same machine.
  • used Roon with headphones on a Mac using Roon Bridge, all joy.
  • update for Bluesound Node 2i , installed it so on latest there.
  • new speakers arrive, excitement, listening and … nice but what are those artifacts in the sound???
  • tested Audio clock trim enabled and disabled on Bluesound Node 2i, no joy.
  • changing from Bluesound Node 2i to RoPieee, joy bliss happiness!!!
  • checking all cables on Bluesound Node 2i, try again, nice sound but artifacts in sound remain, MQA blinking on/off irregular on the display of the Hegel.
  • checking RoPieee, all joy, no disco on the display of the Hegel.

What is going on?

MQA is also blinking when using the RoPieee and USB, but no artifacts in the sound.
MQA authentication always shows in the signal path but on the Hegel it blinks.
The issue above was with the Bluesound and RoPieee in one zone, now are they separated and will watch the behavior.

With the RoPieee on its own the MQA blinking is over.
Both zones together influence each other , nice observation.

It could be that the Node 2i IS a full MQA renderer and Ropiee is not.

Are you playing to a single zone, or to multiple zones synchronized?

If you’re playing MQA out to a single zone, it should get there unmolested.

If you’re synchronizing zones… I think that Roon injects extra samples into some streams to compensate for slightly different clock rates in different output devices, to keep things synchronized – so, I wouldn’t be surprised if the zones whose clocks are running slower and which are thus getting some extra samples to maintain sync are seeing their MQA bitstream get broken.

[but as always I invite someone who Actually Knows Things to correct me]

I had two zones synchronized, but found out that that was not the smartest thing to do.
It was just for comparison but that did not work well.
Now i am running solely on RoPieee as a streamer with USB.
The Bluesound Node 2i will be used as a headphone setup, this way i can hear what is going on and test some more.

1 Like