My DAC clicks when the sample rate changes - How do I turn MQA off?

I am not pro MQA. But this OP’s problem is with his DAC. MQA just happens to be what triggers it. If the OP were to use Qobuz he would have the same problem. If it is that onerous, just convert the sample rate to something fixed before feeding the DAC.

1 Like

I think you mean Andrew not the OP, Andrew doesn’t do hi-res so he would only sign up for the HI-FI offering from Qobuz and that would limit Qobuz and Roon Radio to streaming of 16/44.1.

If Tidal offered the same option that would work as well.

True, but he is a Tidal user and not a Qobuz user. This thread is “Prefer Tidal FLAC over MQA option” so in this context, as a Tidal user, his point is that this feature request would solve the issue.

However to your point bringing a “focus” functionality to streaming in Roon would solve the issue as a Qobuz user as well. For example, I subscribe to the hi res tier of Qobuz, so when I play music through Roon using Qobuz one of my DACs clicks upon sample rate changes. However, if I use the Qobuz app or even just the browser page, as a hi res subscriber I can select 16/44 only and solve this issue with this particular DAC. So right now Qobuz has a “focus” option and Roon does not! Roon needs to catch up :wink:

1 Like

My 2.5k Holo Spring DAC will also click when changing sample rate or PCM to DSD vice versa. I already get used to it. It is not big deal. Try Roon focus and filter off to a common sample rate and play from there.

Because Tidal only does 44.1 except for MQA artificial Hi-Res

Interesting, I wonder if this is the same issue as in my D2 or just the relay clicks?

Sorry if you posted this previously, but does your DAC click when the sample rate or bit depth changes? (or both?)

I am having a hard time understanding why you percieve these clicks as disturbing, but thats another matter though… :wink:

I wouldn’t say it is disturbing. Just annoying.
If you had the choice of having a clicking sound between tracks or having normal silence between tracks which one would you choose?
All I want is to have the choice to turn off MQA so Tidal ONLY plays 44.1 tracks.
I don’t think that’s a big ask, particularly as I paid lifetime membership before MQA came along and there were never any clicks then.

It’s not the relay that ‘clicks’ when the digital stream changes from PCM to DSD (or visa-versa), it’s just a very quiet, high-frequency ‘click’ when the change is made. I don’t have a great deal of DSD material anyway, so I didn’t notice it a great deal, just occasionally. And when it did happen, it wasn’t obtrusive or irritating at all.
Now I have my Roon core/Nucleus set to upsample PCM to DSD, it doesn’t happen at all, as the A1 receives a purely DSD stream from the core.

@a.dent

While Roon may not have the exact option you have asked for it may be able to do what you want and stop the clicks.

All you have to do is change a couple of settings. Note that you can still let Roon do the first MQA unfold so you get the best possible output.

If you have an MQA capable DAC the first thing you need to do is tell Roon it is NOT MQA capable. Go to Settings / Audio and click on the gears to the right of your DAC and select Device Setup and choose No MQA Support for the MQA Capabilities option.

Then you need to configure DSP Sample Rate Conversion for your DAC. While playing a track to your DAC click on the Speaker Icon at the far right of the ribbon, then click on DSP on the popup menu and then enable Sample Rate Conversion. Once it is enabled select CUSTOM for how Roon manages output sample rate and then set all rates over 44.1 to be down sampled to 44.1.

Then play an MQA encoded track and you will get 44.1 output.

Hopefully this will stop the clicks you are hearing.

Please note that I set all sample rates greater than 44.1 to 44.1 to be safe.

Tim

1 Like

If my DAC clicked when changing file types, I might be looking at a DAC that didn’t.

2 Likes

:slight_smile: I couldn’t care less. But you obviously do, so why dont you get a DAC that can switch sample/bit rates without mechanical noise then?
If you’re listening to Tidal playlists i assume you are not sitting and listening concentrated, so perhaps a cheaper DAC without relays could do?

2 Likes

Ditto. I wouldn’t swap my Lumin A1 for the world (well, maybe for an X1 :stuck_out_tongue: )
It’s that bloody good!

1 Like

Dear Tim,
Thanks for the comprehensive reply.
I did actually try this earlier and it does work.
The only downside is when I want to listen to a full album of Hi-Res I have to disable DSP.
Not a big deal really and if there isn’t any future upgrade to Roon to disable MQA this is what I will continue to do.
Cheers.

But then I would have to plug the cheap DAC in whenever I listened to a Tidal playlist.
Hardly practical but I guess it would work.
A simple choice in Roon to “prefer 44.1 over MQA” would be better.

Anyway I’ll use DSP to convert everything to 44.1 when listening to Tidal playlists as suggested above by @DrTone and @anon97951896.

I’ll continue to disable DSP for all my stored files.

Thanks for the advice @anon72719171.

I still don’t see why I should have to compromise on sound quality by getting a cheaper DAC when the problem is not related to the DAC but the Roon/Tidal integration.

Yes, thats the drawback… A separate playback chain for Tidal mixed playlists. :neutral_face:

Otherwise, the suggestion to set a specific samplerate will do just fine, for some situations.

Don’t have to disable DSP.
Just define two DSP presets, switching is just a few clicks.

As a Roon renter (annual subscriber) I definitely would NOT want a click between tracks. The silence/wait while Roon buffers Qobuz and Tidal tracks is annoying enough.

That said, I have trouble attributing the issue to Roon. I mean, it’s your DAC that makes the click. And you can configure Roon to output only 16/44 which presumably would stop that clicking, and my understanding is that you only listen to 16/44 material so it’s not like you are missing the benefits of hi resolution tracks that would otherwise play.

I’m not saying the request is unreasonable. But it does sound like you are asking Roon to solve a problem that is really in your DAC. Yes, you say it’s a really expensive DAC, but I gotta think that the designers of that DAC should know that DAC users play various formats and various resolutions, and don’t want clicks between tracks.

Kind of like the owner of a really fancy Lamborghini that rides super low to the ground complaining about speed bumps or rough roads and asking the city to repave all the roads rather than buying a more practical car. The car wasn’t built to be driven on that type of surface and that choice was made when it was bought.

I am not a fan of MQA’s end to end model, don’t mean to defend MQA (which sometimes sounds very good to me). But this request isn’t about that, it is about clicks that the DAC makes for various format changes - that is a DAC problem.

1 Like

James_I,

Have you used Roon’s “Focus” functionality? What do you think of the “Format” Focus button? I ask because I think you may be focused on the trees (or in this case, a single tree of DAC relay clicking upon sample rate change - one of mine does the same thing) for the forest.

The Format Focus ability gives us the ability to curate based upon, among other things, 16 or 24 bit, all the various PCM rates, DSD/DSF/DFF of various rates, FLAC, MP3, AAC, even “Tidal” and “Qobuz”.

Why not bring this functionality, which is at the heart of Roon’s raison d’etre, to streaming? Could not your argument easily be reversed? I mean any and all of end users desire for whatever Roon does or does not do is really their problem is it not? They should just manually arrange their files in the file system in just such a way and not burden other Roon users with feature requests…:yum: