My Eero + Roon Saga (or: how I finally fixed incessant dropouts on my Eero mesh network)

Short version: If you’re tearing out what’s left of your hair due to constant dropout failures over an Eero mesh network, try placing a wired router (like a MikroTik) between your modem and your Eero gateway, and put your Eero system in bridge mode. This just makes your Eeros into access points, with routing done by a device that’s better at it.

Long version:

I’ve got a large property covered by 8 Eero 6e Pro devices. Our home was never wired for Ethernet and wifi is just the only way to get coverage to our Roon zones. Unfortunately things degraded to the point where we couldn’t go for more than a few minutes without our audio streams failing due to “too many dropouts,” despite having over $1000 invested in this Eero system that’s supposed to just work. To be fair, it does “just work” for any app that isn’t streaming audio; it’s only Roon, Sonos, and BluOS that can’t hold a connection.

I found a few similar issues in the support forum here, but they always ended with “well, you’re using WiFi so that sucks for you.” And to be fair, my Roon server logs were pointing pretty conclusively to networking issues. Also to be fair, I would think Roon could be more forgiving of dropouts and wifi networks by having larger buffers or something, but I didn’t design how it works so maybe I’m wrong.

After months of trial and error to try and isolate the issue, I eventually found that even on a wired connection direct to my Eero gateway, these dropouts were still occurring. It wasn’t a wifi signal issue at all! It seemed to be something inherent to Eero itself. Indeed, if I ran a ping test on a PC hard-wired to my Eero gateway, it was showing sporadic packet loss that corresponded with my audio stream failing, as well as ping times that were all over the map. If I bypassed the Eero system entirely and connected my PC directly to my cable modem instead, everything was fine.

I called Eero support, who first had to walk me through successfully restarting the network - it would only come back up if I first unplugged everything but the gateway node, and then plugged in each Eero one at a time, waiting for each to come online before powering up the next one. But the problem persisted.

Then they had me reduce my network to just 3 Eero devices, but that didn’t work either.

As this seemed like a routing issue more than a interference issue, I went and bought a MikroTik Gigabit router at Amazon for $75 as an experiment. Introducing it into my network involved a bit of a procedure:

  • Powered off my cable modem
  • Connected the cable modem to the router input, and a PC to one of its outputs
  • Powered up the cable modem so it would give the router an IP address
  • Configured the router with a new password and updated its software from that PC, rebooted the router
  • Disconnected the PC from the router and connected it to a switch, along with everything else I wanted hard-wired in my network
  • Connected the switch to an Eero gateway’s ethernet port
  • Connected the router to the Eero gateway’s other ethernet port, and waited for the Eero app to show that all the Eero nodes were active
  • Placed the Eero into bridge mode, waited for the former gateway Eero to spin up with a solid white light
  • Unplugged all other Eeros, and plugged them back in, one at a time after each was solid white.
  • At this point the Eero app should be showing that everything is happy again.

And voila! I’ve been streaming dropout-free for the past two days now. This configuration bypasses Eero’s apparently buggy routing software, using the Eeros only as access points - while the MikroTik does what it’s made for.

It’s important to ONLY connect the primary Eero to the router output in this setup; apparently if anything else on your network is “in front of” the Eero, Eero’s mesh system won’t work reliably. Any wired devices should be connected to an unmanaged switch, that is connected to an Eero.

Anyhow, I wasted a lot of time and money trying to figure this out, so I’m hoping my ordeal will spare someone else this trouble.


this >> “with routing done by a device that’s better at it”

This is a great post. Thank you for sharing. I do exactly the same with Orbi. AP mode all the way.
I think there is far too much ‘trust’ put in these mesh devices trying to do it all.

1 Like

This is a great troubleshooting writeup.

Still, I can’t help but wonder if there is some other root cause. I’ve run Roon on an Eero network since 2016 and never had a problem with dropouts. We have a large home with anywhere from four to seven Eeros. Initially, we had the original v1 Eeros, using the wireless mesh; now we have Eero 6s with a wired backhaul. Endpoints over the years have included various Raspberry Pis (over wifi and wired), Devialet Phantoms (wifi and wired), a Devialet Expert Pro (wifi and wired), and too many AirPlay devices (all wifi) to count. And I don’t recall any dropouts, even with DSD streams to the Expert Pro.

I mention this not because I doubt your experience or your solution. But I do wonder whether there was something else going on–a defective Eero, a bad cable, evil spirits.

1 Like

It’s possible my particularly bad experience is because I mostly listen to FLAC Internet radio through my Roon setup. It may be more sensitive to dropouts. Also, I don’t have wired backhaul between my Eeros - the next step if this problem resurfaces is to use MoCA to try and tie them together through the cable TV wiring in the house as much as possible.

I replaced every Eero as one troubleshooting step, so I don’t think it’s a defective device at fault. Evil spirits are certainly plausible though!!

fwiw, I have FIOS home internet, and once we ditched FIOS TV, I plugged the FIOS “ethernet” cable directly into the gateway Eero. there’s no modem in my network at all.

all other Eeros and devices are connected to a passive switch, which is in turn connected to the gateway Eero.

I’ve had almost no problems.

1 Like

I am here as an Eero user experiencing the same issues. Picked up your recommended wired router to give this a shot, just wanted to check and see if this solution is still working for you.

It helped, but after awhile dropouts returned. Not as often, but enough to be annoying.

Ultimately I ended up setting up a MoCA system to run ethernet over my unused cable TV wiring, which enabled me to hard-wire my player to the network my Roon server is also hard-wired to. 100% solid now, at least until I try to group it with players that are still on wifi.

1 Like