My VPN blocks Roon connection

I’ve just installed Roon on my Windows 10 PC SSD, music is on same machine but on a separate disc drive.
Normally I always have Nord VPN running 24/7 but while Roon itself installed ok it wouldn’t find my files, nor could it find my NAD player - just kept spinning,unless I cut off the VPN then everything is fine.

Is there a way to always run Nord AND run Roon properly?

It needs to be able to handle “split horizon dns” the problem with the vpn is it takes over your routing. you now have an external IP with no route back to inside your home.
See if Nord allows you to exempt certain programs from using the vpn, most do but I don’t use nord.
add Roon to the exemptions.

Good luck.


Thanks for that, I’ll look into it on the weekend when I have time.
I was surprised as I have no such issue using BubbleUpnP on the network or, more recently BlueOS when I bought and starting using the NAD M33. Roon has only been recently certified on the NAD so it’s a new game for me. Cheers.

Thanks for the advice, that all worked out exactly as you said. Nord has a split tunnel feature to add apps as exceptions.A quick reboot and all was well.:+1:

1 Like

You need to add Roon to the “split tunneling” section in your nord settings.

This works fine on OSX and Android Nord apps.

Can’t say for sure on Windows as don’t have any Windows devices.

1 Like

Thanks for confirming - appreciated!