Mytek 192 DSD Raspbian(Buster) driver

(Koen Lensink) #1

allright, having a quiet summer this year, I finally bought an RPI (4B) to replace my 10 year old Mac mini as a NAA.

As I am being relatively new to Linux, it has been an interesting project.

As of this moment, I’m stuck with no driver for the Mytek 192 DSD. There is a guide online for compiling your own, but I’m a bit stuck at loading the firmware/driver

guide by lintweaker: https://github.com/lintweaker/mytekusb2

will this guide still work or am I beating a dead horse?

(Peter Lie) #2

In Lumin U1 (MINI) we load this driver at boot time, so the DAC has to be powered on with USB 2.0 already selected and connected to our streamer. Otherwise it won’t work (in our configuration). What worked for us does not necessarily mean it’ll work on RPi kernel though.

(Koen Lensink) #3

that’s good to hear that it’s still possible to load the driver in linux.

I’m still a bit disappointed with Mytek for having such a weak driver supply for the Mytek 192 DSD, but it’s so good to hear that you still include them in your commercial products.

(Koen Lensink) #4

this is my process so far…
credit for the guide; Lintweaker
this guide can be found at:

Citaat: When using the USB2 interface on the Mytek three pieces of firmware need to be
uploaded to the device. These can be extracted from the Winwows driver.
These files need to be copied to the firmware directory on your system into a
newly created directory ‘mytek’. On most system the firmware directory is: /lib/firmware


downloaded the 3 files and placed them in /lib/firmware/mytek.
only difference with guide is the version of the driver.

next compiling the driver

Citaat: install guidelines for the snd-usb-mytek
– Prerequisites
-kernel headers for current running kernel
-gcc, make etc. for compiling

this is where its al a bit unclear for me, but this is what i did.

  • kernel headers for current running kernel

check kernel version with: “(uname -r)”
kernel version is: 4.19.57-v7l+

check kernel header package with: “sudo apt search linux-headers-$(uname -r)”


im not sure if this is the right output

check if the matching kernel headers for the kernel version are already installed on your system with: “sudo ls -l /usr/src/linux-headers-$(uname -r)”


package is not installed.

next update the package index with: “sudo apt update”
and then install the Linux Kernel headers package for the kernel version with: “sudo apt-get install raspberrypi-kernel-headers”


kernel headers are the newest version.

Citaat: – Building the kernel module snd-usb-mytek

Install prerequisites:
“sudo apt-get install linux-headers-$(uname -r)”

Compile kernel module
excute make (as normal user):
“make”

Install the kernel module:
“sudo make install”

(Koen Lensink) #5

lets see if the firmware can be loaded:
bash mytekusb2-firmware-loader.sh


failed!

(Koen Lensink) #6

if somebody with more knowledge about Linux/raspbian than me(only 3 days :grinning:) could tell me what i did wrong,

(Harry ten Berge) #7

Maybe you should try RoPieee :yum:

2 Likes
(Koen Lensink) #8

Are you implying the driver is included? That’s awesome!
I’m afk right now, but will try it when I’m home

(Harry ten Berge) #9

use this link: http://image.ropieee.org/20190728-ropieee-ose_rpi4-beta.bin

1 Like
(Koen Lensink) #10

thank you very much, I’m downloading it now!

(Koen Lensink) #11

I downloaded it, etched it on the sd card, put it in the pi and booted.
it seems to start up, the splash screen followed by a lot of txt comes by 2x and then nothing but a blinking green led.

(Koen Lensink) #12

after 15min+ staring at a blinking green led I gave up, any idea what I do wrong?

(Harry ten Berge) #13

That’s what RoPieee does. It’s not a standard distro, it’s an applicance that runs RoonBridge.
I was under the assumption that that’s what you’re looking for.

1 Like
(Koen Lensink) #14

ah oke so no video out via HDMI? and controllable via ssh?

but my main struggle is the process of compiling a driver and loading it, I got the assumption that that specific driver is included in ropieee?! is it? I’m not quite sure now :dizzy_face:

(Harry ten Berge) #15

It is.

But again: RoPieee is no regular distro. It does one thing: running RoonBridge.
It has a custom build kernel with support for most USB DAC’s out there.

If you’re looking for an environment where you can compile stuff on your own then RoPieee isn’t for you, and I was too quick with my advice :wink: Sorry for that.

1 Like
(Koen Lensink) #16

oh I think we misunderstand each other, I’m very much looking for Ropieee if the Mytek 192 did is supported by your kernel. Can you confirm that?
I can’t get a lock between the DAC(turning on/off/unplugging/plugging in/change input) and Raspberry.

The last thing I like to do is trying(with the emphasis on trying) to compile a driver.

(Harry ten Berge) #17

Well,

You can try right? If you’ve got RoPieee running you can plugin your DAC and see if it turns up in Roon.

1 Like
(Koen Lensink) #18

ofcourse and I am. but for now still no cigar.

I’ve tried 20190728-ropieee-ose_rpi4-beta.bin and 20190705-ropieee-ose_rpi4-beta.bin as well, but I end up with

splash screen
boot process all the way to: “[ ok ] started network time services”
black screen(monitor gets no signal message)

green led blinks franticly for about 1 min

splash screen
boot process all the way to: “[ ok ] started network time services”
black screen(monitor gets no signal message)

green led blinks franticly for ever.

and nothing in Roon…

(Harry ten Berge) #19

the screen is ok. ropieee has no interface as such. i assume it’s connected to the internet while installing?
that’s required.

And DAC connected and turned on?

1 Like
(Koen Lensink) #20

oke im in the ropieee.local

but I still don’t see it as a bridge in Roon

with same setup/hardware it works with raspbian so I guess its not setup/hardware related