Mytek Brooklyn an interesting issue (Ended up being a Pi issue)

Hey Marco

So sticking to headphones use with the Brooklyn, a direct connection from your iMac was never an issue? But the RPi source is?

Are you using the new RPi3B+ ? Which supports dual-band 802.11ac. Maybe try that with 5GHz WiFi?

Hi Sean,

you are correct. Imac connection through USB is fine. The problem show up with RPi USB. I am using the latest RPi3B+ and I can confirm that via wifi the crackles are minimal (still annoying but you can make an effort in ignoring them). Clearly Ethernet is bringing up the worst and this is what make me think that most likely there is an interaction between Eth/USB that mess up the signal. However said that I cannot figure out why this is audible only with the headphones and not when the mytek is connected through RCA out. I hope that Mytek support can shed a light on this. At this point I am happy to buy a USB regen if solve the problem but I want to make sure it is the case.

1 Like

Hi Marco. And you’ve tried using 5GHz ac WiFi?

yes, sorry I didn’t specify it. Wifi is 5Ghz if I use the lower one I have drop outs.

1 Like

If you were down the road I’d happily offer you try my Allo USBridge (which is rock stable with PCM768kHz and DSD512), just to see if you can have a working ethernet solution in the living room.

I’m pretty sure it’s your RPi (since your iMac feeding your Brooklyn was fine with headphones) but you need another networked USB endpoint to test in the living room.

I really think that there’s more to it than the usual “it’s the pi”.
Marco is having these issues even with 44.1 content.

True, but testing another networked USB endpoint in the living room as I suggested, might help confirm if it’s the Pi or not?

@Marcor , do you have a laptop that you could run RoonBridge on (test both ethernet and WiFi), in the living room with the Brooklyn + headphones?

I wonder if the Brooklyn headphone output is more revealing than the analogue RCA outputs of the Brooklyn and Devialet - i.e. the issues are still there but less obvious with speakers than with headphones?

Ok, this is weird
@spockfish probably you can shed some light.
First to Sean point, Ethernet I know for sure that is working fine, the whole house is cabled with giga bit ethernet and several things are attached to it. I can connect the Brooklyn to my daughter’s laptop in the living but that will be through wifi not cable ethernet.
Now for the surprise of the evening… (at least here in NZ).
I came back from work with a couple of things to try.
First changing the power cable as suggested by Mytek support that thinks could be a ground issue.
Second I wanted to try to connect the RCA line out while testing the headphone just to see if there is some problem with open loops.
So I go back to the room where I have my Devialet, connect the RPi and the mytek, change the power cable and switch it on. I give a try to the headphones first as yesterday night I only checked the mytek RCA out and not the headphones and no crackling! at all even at DSD 256. First I think the RCA connection did the trick so I unplug the RCA but still no noises. Ok, so no the RCA, that means that the power cable was busted. To check I swap again the cables and still no crackling! At this point I am starting to wonder what the heck is happening. Probably the power board, the one where the devialet is attached is a better one. So I unplug it, move everything back to the study where I am doing all my experiments, connect back the RPi, the mytek the power board all good to go, first three notes and the crackles are back!
Grasping at straw I remember the only thing that is different from the rest of the house and the room with the devialet is the little Ethernet switch that is still an old 10/100 Mbps. I go back unplug it, get it out from the cabinet (swearing ensued), back to the study. plug the switch between the RPi and the wall and by magic the noises are gone!
Went through the whole song at DSD without any glitch. I am really at loss here

1 Like

Interesting. So the RPi prefers a 10/100 Mbps switch over gigabit?

I remember seeing Jussi (of HQPlayer) say this about some networked endpoints (their physical interface performs better on 100Mbps than gigabit), so since then (without even asking for the nitty gritty details) all my Roon endpoints plug into a NetGear FS108 now.

Looks like it. In order it seems that RPi works better with 100mbps then wifi and last giga eth.
At the end of the day I think that the Mytek usb is sensitive enough to pick up the noise and amplify it. Just to clear out any possible remainjng doubt, I will try a couple of extra tests.
On will be to connect the line out of the Brooklyn to the Devialet but this time using the giga Ethernet in the RPi, I would expect In this case to hear the noise. But this will require some re cabling anb probably I will do it during the weekend
The other will be to connect the RPi usb to the devialet but using the giga ethernet for the RPi. I am curious to see if the Devialet will pick up the same noise.
Once I have done these tests I will have a couple of options. One is to buy a new giga eth switch and use that in place of the 10/100 so I can use the 10/100 for the Brooklyn. But first I will need to check that the devialet works fibe with giga Ethernet (at this point better safe then sorry)
The other is to buy a usn regen as it seems clear this is a problem with the usb signal. In this case I would be able to use wifi as well.
At least I have some valid options now

I think this is a similar problem to this: Raspberry Pi 3b+ Clicking on USB Audio Devices. Currently the only way to fix it was to swap back to a non gigabit Pi3 (previous generation) or use an old netgear 10/100mbs switch.

I found that if I changed my managed switch to force the port to 100mbs I still had the problem.

In my mind it’s a problem with the latest Pi.

Hello Duncan,

just to make sure I get this straight. You connected your RPi to a managed gigabit port but forced the port to be a 100mbs and still the Pi was crackling. Did you try using a real 100mbs switch? I am asking so I can map out all my possibilities.

OH… wait a moment…

You have a Pi 3B+… Which is capable of doing gigabit ethernet (while the older models only go up to 100 mb). But I’ve seen reports from networking issues with the Pi on gigabit.

There are fixes in the kernel, as there is a setting to disable this.

I’ll make sure this fix is in the next release of RoPIeee.

:slight_smile: that would save me the money for an ethernet switch!

1 Like

Yeah… but it’s more complex then I originally thought :wink:

Bottom line is that on the Pi 3B+ the performance with 100MB is better than with 1GB.

And yeah, considering the bandwidth issues that the Pi has this can lead immediately to issues that you have experienced.

HI Marcor,

2 tests, my Unifi Managed switch with the port forced to 100mbs still caused dropouts- but using a cheap old netgear FS108 10/100 switch all was fine (and I just plugged it in between the manage switch and the pi.)

I think there is something amiss with the Pi / data bus that is causing a timing issue with the USB?

What is the flow control setting in the managed switch?

tried it with both flow control enabled and disabled; no difference.

Hi Marco,
My Brooklyn Dac +, has the same issue with 24 bit recordings - it works fine with standard resolution and dsd - switching MQA On seems to solve the problem.
For now I can only listen to 24 bit recordings with MQA filter - I tried the Dac with 2 different PCs, before contacting Mytek who acknowledged the issue and informed me that it will be dealt with via Firmware update.


Looks like you’re talking about a different issue than the one from this topic, but FYI: I had the same problem as yours with the Brooklyn DAC+. It seems to have been solved with the latest firmware v1.22.