Mytek Brooklyn an interesting issue (Ended up being a Pi issue)

Last September I bought a Brooklyn with the idea of using as DAC/amplifier for my Audeze LCD-3. The Brooklyn was connected via USB to my iMac and has been performing quite well apart the limitation of not being able to play native DSD on mac.
Recently I decided to move my set up from the studio to the living, to do so I had to find a Roon end point. I decided to try my hand with a Raspberry Pi with Ropieee (the purchase of headphone and DAC was still to fresh in my wife’s memory to allow me a more expensive solution).
The set up of Pi went without an hitch and I was able to stream music via Wifi in a couple of hours. However after a bit I started noticing some crackling noises at higher resolutions (I wrote about them here Noise - ticks and pops on USB (Solved) )
I got in touch with @Spockfish who suggested me to go back to ethernet and start from there to debug the issue.
Weirdly enough the ethernet connection revealed itself to produce even more ticks even at 44.1 kHz.
As the Brooklyn was not showing the issue when connected to my computer I started looking at the Pi as culprit. To investigate the issue I connected the Pi to my Devialet using the same connection, ethernet for the Pi and USB for the Devialet. I was expecting the same problems that plagued the Brooklyn but instead the sound was perfectly clean up to 192 kHZ and even to DSD 64 over PCM.
Surprised at the result I decided to investigate more the connection between the Pi and the Mytek, so I disconnected the Pi from the Devialet USB and connected it again to the Brooklyn, but this time instead using the headphones I connected the RCA out of the Brooklyn to the line in of the Devialet.
Even in this case the sound was perfect. I tried to push the Mytek up to DSD 256 and still no crackling.
I tried again using the headphones and again the noises showed up. I tried all the possible settings available on the Brooklyn with no success.
To sum it up. The problem can be reproduced connecting the raspberry Pi USB and playing only through the headphones. Using the same connection but with RCA line out the problem doesn’t persist.
I got in touch with Mytek support and I am waiting for a reply, but in the meantime I thought to write here in case anyone experienced a similar problem.
One possible theory is that perhaps the USB signal is not perfectly clean but it is treated differently according if gets amplified internally or passed through a line out. But I don’t get why this would be the case. any way if this was the reason a USB regen would do the trick, however this doesn’t explain as the same USB signal in the devialet doesn’t create any issue.
Has anyone any idea?


An interesting issue indeed. As a fellow Brooklyn user I decided to investigate it. I’ve never used the Brooklyn headphone amp, as my Sonic Frontiers preamp has a very nice headphone section. So I re-configured the DAC to auto headphone position and listened to a few tracks with my Sennheisers, both DSD128 and 32/352.8 up-sampled. No crackling noises here. The big difference between our setups is that I’m using a CuBox-i2 to run RoonBridge over ethernet. The reason I’m using the CuBox instead of a Pi is because I read somewhere that they have a better USB implementation. So I guess it still looks like your problem lies in the interface between your bridge and DAC. Good Luck Marco!

Thanks Milton,

this is a very valuable piece of information. It could be that the USB signal coming from the Pi is indeed noisy but for some reason the signal processing happening to the line OUT manage to clean it up, while the internal amplifier is not able to do the same and amplify the noise. As USB and ethernet share the same BUS on the Pi this would probably explain why via wifi the noise is a lot less evident. If this would be true a Wyrd or a USB regen could solve the issue as the signal would enter the Brooklyn cleaned up. Just a question if you don’t mind, when you tried the headphones was the line out still connected? When I did the test I disconnected it, it shouldn’t make a difference but at this point I don’t want to live anything untested

Hey Marco - as you guessed, I left the line out connected & preamp turned on when I hooked up the headphones. Just to complicate things further I use XLRs to my preamp, not RCAs…I’ll try phones with no other connections tomorrow & let you know if that changes anything.

Hey Marco

So sticking to headphones use with the Brooklyn, a direct connection from your iMac was never an issue? But the RPi source is?

Are you using the new RPi3B+ ? Which supports dual-band 802.11ac. Maybe try that with 5GHz WiFi?

Hi Sean,

you are correct. Imac connection through USB is fine. The problem show up with RPi USB. I am using the latest RPi3B+ and I can confirm that via wifi the crackles are minimal (still annoying but you can make an effort in ignoring them). Clearly Ethernet is bringing up the worst and this is what make me think that most likely there is an interaction between Eth/USB that mess up the signal. However said that I cannot figure out why this is audible only with the headphones and not when the mytek is connected through RCA out. I hope that Mytek support can shed a light on this. At this point I am happy to buy a USB regen if solve the problem but I want to make sure it is the case.

1 Like

Hi Marco. And you’ve tried using 5GHz ac WiFi?

yes, sorry I didn’t specify it. Wifi is 5Ghz if I use the lower one I have drop outs.

1 Like

If you were down the road I’d happily offer you try my Allo USBridge (which is rock stable with PCM768kHz and DSD512), just to see if you can have a working ethernet solution in the living room.

I’m pretty sure it’s your RPi (since your iMac feeding your Brooklyn was fine with headphones) but you need another networked USB endpoint to test in the living room.

I really think that there’s more to it than the usual “it’s the pi”.
Marco is having these issues even with 44.1 content.

True, but testing another networked USB endpoint in the living room as I suggested, might help confirm if it’s the Pi or not?

@Marcor , do you have a laptop that you could run RoonBridge on (test both ethernet and WiFi), in the living room with the Brooklyn + headphones?

I wonder if the Brooklyn headphone output is more revealing than the analogue RCA outputs of the Brooklyn and Devialet - i.e. the issues are still there but less obvious with speakers than with headphones?

Ok, this is weird
@spockfish probably you can shed some light.
First to Sean point, Ethernet I know for sure that is working fine, the whole house is cabled with giga bit ethernet and several things are attached to it. I can connect the Brooklyn to my daughter’s laptop in the living but that will be through wifi not cable ethernet.
Now for the surprise of the evening… (at least here in NZ).
I came back from work with a couple of things to try.
First changing the power cable as suggested by Mytek support that thinks could be a ground issue.
Second I wanted to try to connect the RCA line out while testing the headphone just to see if there is some problem with open loops.
So I go back to the room where I have my Devialet, connect the RPi and the mytek, change the power cable and switch it on. I give a try to the headphones first as yesterday night I only checked the mytek RCA out and not the headphones and no crackling! at all even at DSD 256. First I think the RCA connection did the trick so I unplug the RCA but still no noises. Ok, so no the RCA, that means that the power cable was busted. To check I swap again the cables and still no crackling! At this point I am starting to wonder what the heck is happening. Probably the power board, the one where the devialet is attached is a better one. So I unplug it, move everything back to the study where I am doing all my experiments, connect back the RPi, the mytek the power board all good to go, first three notes and the crackles are back!
Grasping at straw I remember the only thing that is different from the rest of the house and the room with the devialet is the little Ethernet switch that is still an old 10/100 Mbps. I go back unplug it, get it out from the cabinet (swearing ensued), back to the study. plug the switch between the RPi and the wall and by magic the noises are gone!
Went through the whole song at DSD without any glitch. I am really at loss here

1 Like

Interesting. So the RPi prefers a 10/100 Mbps switch over gigabit?

I remember seeing Jussi (of HQPlayer) say this about some networked endpoints (their physical interface performs better on 100Mbps than gigabit), so since then (without even asking for the nitty gritty details) all my Roon endpoints plug into a NetGear FS108 now.

Looks like it. In order it seems that RPi works better with 100mbps then wifi and last giga eth.
At the end of the day I think that the Mytek usb is sensitive enough to pick up the noise and amplify it. Just to clear out any possible remainjng doubt, I will try a couple of extra tests.
On will be to connect the line out of the Brooklyn to the Devialet but this time using the giga Ethernet in the RPi, I would expect In this case to hear the noise. But this will require some re cabling anb probably I will do it during the weekend
The other will be to connect the RPi usb to the devialet but using the giga ethernet for the RPi. I am curious to see if the Devialet will pick up the same noise.
Once I have done these tests I will have a couple of options. One is to buy a new giga eth switch and use that in place of the 10/100 so I can use the 10/100 for the Brooklyn. But first I will need to check that the devialet works fibe with giga Ethernet (at this point better safe then sorry)
The other is to buy a usn regen as it seems clear this is a problem with the usb signal. In this case I would be able to use wifi as well.
At least I have some valid options now

I think this is a similar problem to this: Raspberry Pi 3b+ Clicking on USB Audio Devices. Currently the only way to fix it was to swap back to a non gigabit Pi3 (previous generation) or use an old netgear 10/100mbs switch.

I found that if I changed my managed switch to force the port to 100mbs I still had the problem.

In my mind it’s a problem with the latest Pi.

Hello Duncan,

just to make sure I get this straight. You connected your RPi to a managed gigabit port but forced the port to be a 100mbs and still the Pi was crackling. Did you try using a real 100mbs switch? I am asking so I can map out all my possibilities.

OH… wait a moment…

You have a Pi 3B+… Which is capable of doing gigabit ethernet (while the older models only go up to 100 mb). But I’ve seen reports from networking issues with the Pi on gigabit.

There are fixes in the kernel, as there is a setting to disable this.

I’ll make sure this fix is in the next release of RoPIeee.

:slight_smile: that would save me the money for an ethernet switch!

1 Like

Yeah… but it’s more complex then I originally thought :wink:

Bottom line is that on the Pi 3B+ the performance with 100MB is better than with 1GB.

And yeah, considering the bandwidth issues that the Pi has this can lead immediately to issues that you have experienced.

HI Marcor,

2 tests, my Unifi Managed switch with the port forced to 100mbs still caused dropouts- but using a cheap old netgear FS108 10/100 switch all was fine (and I just plugged it in between the manage switch and the pi.)

I think there is something amiss with the Pi / data bus that is causing a timing issue with the USB?