Mytek Brooklyn USB HID not working under ropieee

I have been using my Mytek Brooklyn Dac for some time now - using my Raspberry Pi3 as endpoint. I was using rasbian - and therefore missing the native dsd playback functionality.

Fortunatly i found the RoPiee image - and now i can hear native DSD on my Mytek Brooklyn.

But - the volume control stopped working.
When i adjust the volume in Roon - it does not adjust the volume - but changes the “Clock Source” Control.
Is this a consequenze of using DSD enabled kernel? or am i missing something?

In alsamixer - i can see that dont get an actual volume control - but only the clock source - so i guess that is why it does not work.

Anyone who has solved this? - I am so used to being able to control the dac’s pre amp volume directly from roon :slight_smile:

Best regards

Hi Again!
Just tried another microsd card with #audio-products:diet-pi on - and here the volume control is shown in the settings (alsamixer) - but no native DSD possible there.

So i guess the tradeof of using native-dsd is that volume through HID is not possible :frowning:

I need to look into this, because I’m not convinced that the one thing is related to the other.

Native DSD on RoPieee is working because RoPieee runs a patched Linux kernel. The volume not working might just be a configuration error on Alsa side of things.


Hi, did you find an answer to this? I’m about to get a Brooklyn DAC+ and was thinking about setting up a Ropieee endpoint to use with it.

I’m looking into the volume issue as we speak as a new release is imminent.
Challenge is that I don’t have hardware that behaves like the Brooklyn.


not sure if this can help but I am using a Mytek Brooklyn with Ropieee and the volume is working properly in the sense that changing the Roon volume changes the Ropieee and changing the volume on the Mytek change the volume in Roon. The issue I am finding is that every time I switch OFF and ON the Mytek the volume jump to a default value of -20 dB on the Mytek (45 in Roon volume) that is very high. Setting the volume to min 0 and max 30 doesn’t help as the Mytek once switched on always revert to the same -20 value.
However once you take care of lowering the volume to an acceptable level after switching On the device, it works fine.
My settings are in Roon:
Volume Control = Device volume
and on the mytek:
USB volume = dB V
ol Control= Anlg
One thing I noticed is that if for some reason you change the Volume Control in Roon to DSP or Fixed Volume you cannot go back anymore as Roon ignore any other option. The only solution I found to walk around the issue has been to use the Load defaults on the left of the settings.

hope it helps


1 Like

Thanks for your extensive report.

So basically you’re saying that volume control works. Even after a reboot of RoPieee.
But if you switch off/on the Mytek itself, then you have an issue with the volume. Right?

Hi @spockfish

For the limited testing I have done so far the volume is working apart the initial start at high volume when I switch on the mytek.
Regarding the reboot of the ropieee I am not 100% sure because I haven’t actually tried to reboot and then check. However if the Ropieee reboot automatically every night at 3am as specified in the setting I can say that the volume behave as mentioned before as the result I have highlighted has been the same from the beginning.
One thing I haven’t tested is to reboot the Ropieee when the Mytek is switched on and then check the volume. I can do that this evening.

Ok, I tired the last possible scenario I can think of.
I switched on my Mytek, the volume as usual was -20dB on the mytek screen (45 in Roon). I lower it and started listening music. tried to change the volume both in Roon and using the Mytek volume and everything worked as expected. At that point I stopped the music and leaving the Mytek on I rebooted the Ropieee. After the reboot the volume went back to -20dB (45 in Roon), I lower it and started listening music again with the volume working properly.
This is using the previous settings I wrote about
In Roon
Volume Control = Device volume

and on the mytek:
USB volume = dB V
Vol Control= Anlg

Basically the only problem I am finding is that doesn’t remember the Volume setting that was used last time before being switched off so every time is either switched on or the Ropieee is rebooted the volume revert to what most likely is the default.
Please let me know if you need me to do further testing