NAA Software On a Mac

yikes on the loud fan. Yeah, that would make me a little crazy.

If I had that issue, I’d be looking seriously at a Rasp Pi solution (or similar)

There is no advantage running NAA on the same computer that is running HQPlayer. The whole idea of NAA is to enable a minimal footprint HQPlayer output on a distant Ethernet connected device. Running them on the same computer is just replicating output capability to no advantage. It is like running Roon Core and Roon Bridge on same computer.

I would suggest running HQPlayer on the Roon Core or your new i9, leaving NAA only on the two system streamers. You can then choose which of them to send HQP output to and have Roon/Roon Bridge to the other. If you want to group them you can shift to Roon Bridge for both.

That way you can upgrade the RoonCore if you want, or use the i9 to try EC modulators sending DSD 256 to one of your DACs. The streamer Minis should be running output software only. Either NAA or Roon Bridge and nothing else. You might try comparing them with a different low footprint device, like an ultraRendu.

Try sending DSD 128 or 256 to your DACs through HQP.

OK, so, being curious, I installed HQPlayer on the core.

In Roon, I added the new instance of HQPlayer, leaving “localhost” as the location.

Now, in HQPlayer, I’ve tried a few things, but I’m not seeing any of the NAA’s in the Device dropdown

I clicked the “Allow control from network” button. (Also tried without.)

Selected “Network Audio Adapter” from the Backend dropdown. (Also tried all other options.)

Sooooo… what do I need to configure differently to get the NAA Macs to appear in the Device dropdown?

EDIT: NEVERMIND. I still had HQPlayer running on the other macs. Turned it off and am now seeing the Devices.

1 Like

ok, had a little chance to toy with this new arrangement. All seems fine with PCM. Sounds great. Better than before? Ahdunno. Very hard for me to go back and forth and remember what I heard. But it sounds good, and supposedly it’s the “right” way to do it, so I’m happy with that. :wink:

However, DSD really is a no-go. I hear the music, but it’s mostly white noise. Same behavior as before I did the switch (which at that point I chalked it up to the limited processing power of the mini). But it’s still exhibiting the same behavior with HQPlayer on the core, and NAA on the endpoint mini.

I’ve tried 256/128/64, etc…, and several of the filters. No joy.

I’m fine sticking with PCM, but any ideas why DSD performs this way?

All the DACs do the same?

Make sure the output is not multiple of 48k, IOW, that you don’t have 48k DSD checked. This is commonly not working with DACs.

Also make sure the audio device is not set as default audio output device for macOS sounds or notifications. And you select the DAC explicitly, and not the “Default output device”. And that you don’t have any other applications running that could be using the same audio device.

You could also try to boot the endpoints into the NAA OS image instead of macOS.

You need to uncheck “Auto rate family” at least. Otherwise it’ll try to play 48k family source rates at 48k multiple DSD…

Thanks, jussi, but I tried that, too.

Seems to make no difference. Loud static, clicks, pops. (But I do hear music in the background!)

I’m still running version 3.x of HQPlayer, if that’s anything.

I noticed from the settings dialog that it is 3.x. You could also try with 4.x trial if it makes any difference.

I assume NAA is latest 4.1.1?

Something is not quite right. How are the per-core CPU load graphs on the machine running HQPlayer?

Does it get better with for example poly-sinc-short-lp-2s?

This is playing PCM.

Screen Shot 2020-07-17 at 11.56.52 AM

The filter you suggested isn’t available that I could see in 3.x. I’ll test 4.x later today. And yep on NAA being current… it was just downloaded over the weekend.

I’m certainly interested in solving it, especially if others are able to do it. But if you look at the components in my audio system (post 17), I really don’t know that DoP will make any discernible difference.

Yes it is there, IIRC with name “poly-sinc-shrt-2s”.

How are the per-core load histograms when playing? 12% load sounds a bit low’ish for DSD256 output with those settings. Does HQPlayer indicate that it is doing output at 11.3 MHz?

ah, gotcha. Was looking for “poly-sinc-short-lp-2s”

No difference in sound.

here it is playing DSD, so a lot more load.

Screen Shot 2020-07-17 at 2.58.47 PM

Do you mean here? (sorry for the cursor photobomb)

Screen Shot 2020-07-17 at 3.04.50 PM

That percentage is not very indicative, so you need to open the window that shows CPU load graphs per CPU core over time. That filter is quite a bit lighter than poly-sinc-ext2, so with ext2 the load would be even higher.

Yes, that is just DSD64, so for DSD256 output the load would be notably (4x) higher.

I also had problem about NAA run in Macbook.
I hope Desktop PC run Roon Core+HQplayer, and let my Macbook Pro be a HQPlayer NAA and Roon Bridge.
DeskTop (Roon Core)+ MacBook Pro (Roon Bridge) works fine.
DeskTop (Roon Core)+ MacBook Pro (HQPlayer) works fine.
But I try DeskTop (Roon Core + HQPlayer) + Macbook Pro (HQP NAA) not work.
In the HQPlayer setting, backend NetworkAudioAdapter no Device found.
And in Macbookpro NAA command show as below~

networkaudiod Copyright (C) 2011-2020 Jussi Laako / Signalyst. All rights reserved.

create coreaudio engine

Network interfaces:

if[en0] ipv4=192.168.0.30 ipv6=fe80::1846:330e:e5d5:acc%en0 idx=4

if[lo0] ipv4=127.0.0.1 ipv6=::1 idx=1

listen discovery on en0

clSocket::SetOption(): setsockopt(…, 41,12, …): Can’t assign requested address

Socket failure, falling back to IPv4-only!

listen discovery on 0.0.0.0

clSocket::Bind(): bind(): Address already in use

listen discovery on 0.0.0.0

clSocket::Bind(): bind(): Address already in use

listen discovery on 0.0.0.0

clSocket::Bind(): bind(): Address already in use

listen discovery on 0.0.0.0

Have some one can show me how to solve it?

Is your macOS Firewall on? In my experience with macOS NAA, I needed to turn it off to work. Also you probably need to reboot.

image

1 Like

Remember to run it with “sudo”.

Some other process is already keeping the port busy. You may need to reboot and try again.

1 Like

Thanks your kindly help. I had solve the issue.
It really be occurs by the firewall (should be off).

1 Like