Nativ Vita stopped working with Roon after 2.0 upgrade of Nucleus

Roon Core Machine

Roon Nucleus
Operating System
Version 1.0 (build 254) production
Roon Labs Software
Version 1.0 (build 14) production.
Roon Server Software
Version 2.0 (build 1148) production
Internal Music Storage

2000GB, Samsung SSD 860 66% of 1848 GB available.

Networking Gear & Setup Details

Wired Lan

Connected Audio Devices

Mac Mini
Marantz 8805A
Peachtree Nova150
several other devices with streamers, like sounders and TVs but never use them

Number of Tracks in Library

22,000 tracks

Description of Issue

I have been using a Nativ Vita for several years with Roon. Most recently, the last few years at least, as a RAAT endpoint. The Vita is on a wired lan to the Nucleus and outputs USB to my Luxman Dac.

Its worked relatively flawless for the last couple of years (mostly since the Nativ team disappeared and stopped pushing updates…;-).

However, when I upgraded the Nucleus and all my other devices to 2.0 (now build 1148), I could no longer start Roon from the Nativ Vita. I could however see it on my list of audio devices and choose it to play to. It worked even this afternoon, when I tried playing a few songs from the Roon Remote on my iPhone. Then the Nativ restarted and now I no longer see it from my remote devices as a selectable audio option. However, I do see it in a list of all the devices on the Audio page, and its is still highlighted in grey as an enabled device.

When I go to play Roon from the Nativ interface, it tells me that I need an upgrade for the Roon Remote. The Nativ Vita ‘sees’ and connects to the Nucleus 2.0 Core. However, the Vita shows that a "Software Update is needed for this tablet (v1.7 build 500).

When I check for an update on the assisted Google pay link, I get the following message:
Roon Remote - This app isn’t compatible with your device. Contact the developers for more info

So, here we are…

I know that there were/are issue with the Nativ team, but this application has worked fine for years and seems to have only died because of my, perhaps naive, upgrade to Roon 2.0.

Is there a fix for this issue?

Please let me know.

Thank you,

Dave Z

Hi there.
I moved this to the tinkering section as the Nativ is not officially supported in Roon.
Maybe someone will have an idea here.