Need a startup delay for Control4

Nucleus+ tied to a hegel h390 via USB. When launching Roon from Control4, the Hegel has not yet been turned on and switched to the correct input so the Nucleus doesn’t see it as a valid zone. We just need to add an option for startup delay that we can modify so that the roon source will wait a few seconds before trying to load the zone. Doable?

Hello @Sherif,

Can you please share a short video of this behavior? How are you triggering the Hegel to turn on, through Control4 via IP or does it have auto-detect and it turns on when starting playback?

Is only the Hegel H390 impacted by this issue, as in do other USB devices operate properly? Do you see this issue when starting playback directly from the Roon app?

I start roon by selecting it as a source in control4. This then turns on my hegel, which then enabled the USB connection to the nucleus, and after about 5-10 seconds roon recognizes that the nucleus zone out to the hegel is active and then it shows up in the roon zone list and the control4 app shows the music menu. In control4 programming there is a way to trigger things when roon senses audio, however since I cannot start roon until the hegel is one (no usb link) then it’s not helpful