Need Help Setting Up HQPlayer on Mac Mini, NAA, ultraRendu

I’ve been going 'round & 'round trying to get HQPlayer to work in my system. I’ve read the KBs, checked different threads and forums, etc., without any luck.

Symptom: It looks as though everything is working, but no sound comes through. I can set HQPlayer in Roon, watch the scrubber/timeline go by, see something being played on HQP, but no sound.

My chain is Mac Mini (office) -> ethernet to mesh node (office) -> WiFi to mesh node (living room) -> ethernet to etherRegen -> ethernet to Sonore ultraRendu -> USB to Matrix X S/PDIF -> I2S out to Directstream DAC.

I go into MySonicOrbiter, which spots the ultraRendu. Using Apps there, I switch from “Roon Ready” to “HQPlayer NAA”. In Roon, under “Setup”, I add HQPlayer. Under “Settings > Audio”, I choose HQPlayer and check the settings, taking the defaults.

Using Screen Sharing on a MacBook, I check in with my headless Mac Mini in the other room, and start up HQPlayer Desktop. It sees the ultraRendu/Matrix/DAC and fills in the settings for Backend. (See screenshots below.)

So, I think I’m doing this correctly, but still no sound from the main system, even though Roon seems to be playing a track.

If you could check my screens below, perhaps something will be obvious, and hopefully simple to address.


Setting up HQPlayer via MySonicOrbiter:

Roon’s view in Audio Setup:

And the view from HQPlayer’s Preferences panel:

I’m using HQPlayer 3.0 and I have to set allow network control in HQPlayer

Thanks, @Rugby, but I’ve done that… toggled the button.

What volume setting do you have in HQP ? The range is set to -58dB so if the volume knob is at 12 noon the output will be down 28dB.

I’ll check soon. As I recall, the volume knob was red at 0dB, although I set it at -6dB based on a recommendation I read.

FWIW, I control volume by my amp, with the DAC at 100 and Roon device volume fixed.

So… that’s not likely it, right?

When output zone in Roon is HQPlayer, Roon volume control controls HQPlayer’s volume. If the volume control in HQPlayer is disabled, then no volume control appears in Roon either.

I’ve been able to see volume control in Roon, and its corresponding change in HQP.

However, I’ve discovered that when setting up HQPlayer in Roon’s setups, volume limits are set at all 0, and the dialogue will not let me change any of the values… no min or max numbers are accepted for Comfort and Safety limits… all 0s.

You set the volume control range in HQPlayer instead.

I sorry to report that I still can’t get this sucker to work. All seems well, but still no sound.

I’ve included some more screen shots to see if anyone can spot where I’m going wrong.

Jussi, for some reason, I cannot use the volume knob in HQPlayer. The minimum and maximum volumes are set here:

Once I get HQPlayer set up on the ultraRendu, I can start a track. The scrubber moves, I can see how far along the track is, etc. In the following screen, the vertical bars between the pause button and the track title are dancing around. Note that the device volume is set at -50dB

Over on HQPlayer at this time, I can see the track time count moving along, input from Roon, etc. The volume knob is pinned at -50dB and can’t be changed:

When I took that screen, I noticed the upsampling going up to 384k/32, which may very well exceed the capability of my DAC. To get around that, I lowered the output sample rate within range of my DAC, but still no sound.

When I changed the bitrate down, it seems that my HQPlayer Setup screen in Roon picked up volume settings; prior to this, I couldn’t change them at all:

I feel as though I’m missing something very simple.

Like, I CAN run Roon Core and HQP on the same Mac Mini, and it should transmit output over my LAN to play on the ultraRendu in the other room, right?

It vexes me as to why I can’t get sound output.

I have my volume set as “fixed” in Roon for the HQ player set up menu. I also have different volume settings for min/max within HQ player it

self than you do. Mine works fine so not sure if you want to try changing that. I use my amplifier to change volume.

You have set maximum volume to be -50 which is pretty low. And your minimum volume is higher than the maximum so it doesn’t have effect. Thus you are locked to fairly low -50 dB volume level.

I have HQP-Desktop on a Mac Mini. In the past I’ve run it and Roon Core concurrently on the same machine successfully (with an ultraRendu in the pipeline as well). I transitioned away from the Mini to a separate music server (a sonicTransporter) with HQP-embedded, but am still able to replicate your set-up in most details. I’ve done that today, and it all seems to work fine.

Maybe the issue is some forehead-slapping simple thing, like a mute button on the amp? Or, have you tried taking the Matrix X/SPDIF out of the pipeline (with the uRendu straight into the Directstream DAC’s USB input)? Any chance there is an issue with the Matrix DIP switch settings? IIRC there is a specific DIP switch set-up just for PS Audio, right?

Okay. Got it!

It was a simple problem, and @jussi_laako pointed to it.

I set HQPlayer on Roon for fixed volume, and adjusted the min/max settings based on Jussi’s recommendation, and I am now playing.

Sometimes the simplest thing goes whizzing over my head…

Thanks, all!