Network connection issue on new ROCK / NUC

Roon Core Machine

NUC10i3FNH, 128GB M.2, 8GB RAM

Networking Gear & Setup Details

I have a FiOS Wi-Fi router, and the NUC is directly connected to it via Ethernet.

Description of Issue

I just installed the RoonOS on a NUC10i3 using Roon’s online instructions. It worked fine briefly last night, and I had no problems connecting to the Roon Remote.

Then suddenly the Remote could no longer find the ROCK, and the little boot signal started to appear on the front of the NUC. I tried rebooting several times, and each time the remote could not find it and the boot signal kept flashing.

I reconnected the NUC to a monitor, and the monitor says that it is searching for a network and I should check my network connection. The NUC is connected directly to my router using an Ethernet cable.

I reinstalled ROCK this morning, and am continuing to have the same problem.

Can you help me?

Hi @Timothy_Hodler

During this time are you able to reach the Web UI?


I was able to do it last night before the issues started, but it doesn’t load now.

One thing that seems a little strange to me is that the IP address that was being used for the Web UI last night is a different address than the one from my router. I don’t see how that could have happened… Maybe it doesn’t matter.

Should I temporarily make my home computer into a Roon Core to access the Web UI that way? Or will that cause new problems?

Thanks for confirming, @Timothy_Hodler. Let’s try this — Can you connect the device to a TV or monitor while it’s also connected to power and Ethernet? Some diagnostics information will be displayed here. Can you share a screenshot of that?

Sorry this is a picture not a screenshot but I hope it works…

Timothy, you may try this:

There’s another way to perform the network reset on ROCK. You can connect a USB keyboard and monitor to ROCK and type <ENTER>resetnetwork<ENTER> (no spaces between reset and network). This command will kill all network settings immediately, restoring the built-in Ethernet to go back to looking for IP via DHCP

I tried that, but nothing happens.

Hi @Timothy_Hodler, thanks for sharing. So, it looks like ROCK is starting up okay but it’s not getting any IP address.

Can you try using a different Ethernet cable?

I just tried a new Ethernet cable and got the same result.

FWIW, the first Ethernet cable did work last night for about a half hour before issues began.

Hmm, okay so probably not the Ethernet cable. Have you tried different Ethernet ports? Does the Ethernet port on the NUC look okay? Is it lighting up at all when it’s connected?

Typically there shouldn’t be any reason that ROCK specifically wouldn’t be able to get an IP address, so it’s likely a piece of networking gear or the hardware itself having trouble here. You might want to try installing Linux or Windows and see if the Ethernet connection works there though, just as a test to confirm.

There only seems to be one ethernet port on the NUC, and it appears fine. (It’s brand new…) It doesn’t light up near the port, but I don’t see a light there to light up. The lights on the front of the NUC do light up to indicate the power is on and that it is booting.

I tried multiple ethernet ports on the router, and that doesn’t seem to make any difference.

I am sure this is a stupid & incredibly basic question but if I install Linux, how will I be able to tell that it works via Ethernet?

Hi @Timothy_Hodler

You might want to try a different Ethernet port on your router/switch as well.

Here’s an article on finding your IP address when using Linux:

If you’re not able to get an IP address with a different OS, I’d look into potentially returning/replacing the NUC.

Okay, thanks. Is the LAN/Ethernet light on the front of the NUC? The power LED comes on, as does a light that looks like a cylinder on the left…

LAN indicators are on the back, right on the LAN-port. They should look like this:

Sometimes my NUC loses connection cause the cable connector does not fit tightly into the port (spontaneously, under the weight of the cable it moves to the left or to the right) or I move NUC accidentally.

Thank you!

1 Like