Network Connection Problem(Couldn't connect to metadata)

Around a week ago, I and some other users found that our roon couldn’t connect to the metadata so our library couldn’t update and ARC couldn’t be used, and a week had passed the problem still exists. I guess maybe it’s because we are in China and as we all know there is a network firewall(My network works and my roon version is automatic update), but the problem doesn’t be fixed when I use a vpn to pass the firewall. I guess I need some help, so do you guys have any idea?


@Eric_Zhang2, sometimes the Metadata improver paused issue can be resolved by restarting your Roon Server. Have you tried this? Not sure if the national firewall in China is an issue, but restarting your Roon Server and determining if this fixes the Metadata paused issue would be a first step.

Yes, my Roon Server is installed in my PC so I turn it off and on every day but the problem keeps.

yeah,I am in this trouble too. About one week ago.Hope they can fix it soon.

Because Roon uses Google’s login verification system after the update, it cannot be logged in in China. If it is changed to Cloudflare’s login verification system, this problem can be solved

Alright, I have tried restarting the server while vpn is on instead of letting it launch at my PC startup and now it can work, with vpn connecting. My library can update now but ARC still not ready. Hope this could be fixed soon as possible.

I have the same problem, using VPN, but there are still problems, hope to solve this problem as soon as possible.


我的 server 是在 nas 上,在 nas 上使用 vpn 做代理,还是一样的问题

My server is on nas, using vpn as proxy on nas, still same problem!

Try logging out of the server, leaving the vpn on and starting it up again, I can connect this way, although it will be slower and a slightly worse experience.