Network error ARC

Roon Core Machine

linux pink faun
Linux PinkFaun

Networking Gear & Setup Details

KPN router ethernet Upn setting on!

Connected Audio Devices

Number of Tracks in Library

Description of Issue

ARC connection not ready
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

Hi @Roel_Van_kuppevelt,

According to the error message, Roon can’t configure it automatically.

I would suggest you create a manual port forwarding.

First in the Roon App under Settings -->Roon Arc write down the ip address and port number.

Please take a look at below youtube video (hope it’s your model, if not do a youtube search on your model and port forwarding).

Hope it helps and let us know if you have any more troubles or it’s working.

Kind regards,


Hi @Roel_Van_kuppevelt,

The tech support team wanted to check in since it’s been some time. Have you been able to manually configure port forwarding?

I suggest you install the latest version of Roon and ARC and attempt to automatically configure port forwarding in Roon → Settings → ARC once again. If that doesn’t work, please follow the helpful steps @Maarten_Duits provided above. We’ll be standing by for your response to assist further.

it succeeded by setting kpn box 12 manualy !