Network share disappears/reappears

New user last few days trying Roon out

Roon works fine with Tidal

I have a shared NAS drive: Shared, pathed as Drive “R:” known to all PC’s on network. NAS works fine for all of the machines. No change in several years to NAS - very stable.

In Roon i was able to see “R:” drive and scan music to add to library. Starting scanning. I have 18 k albums so I left and came back in 6 hours. Roon was no longer running

Rebooting Roon was slow. Would initiate and then disappear without error message. Several times

Reboot PC - same thing

Finally could get Roon started via Run as Adminstrator

None of the scanned music was present (could not be found). The R: drive was no longer visible as a drive to use to add music to library.

Deleted all the bad paths

“R:” now visible.

Tried all above again, same thing

R: is “MyNas1”

Added \MyNas1 as a path under Add network folder - no work
Tried SMB - no work (If Igot naming conventions correct)

Is this expected?
Any solutions?
Anything else to try?

Thanks in advance for help. I like Roon but want to be sure it works for me

Please include more details about your setup

  1. Where did you install Roon core?
  2. Roon core is installed on what platform? (Windows, Linux, Apple)
  3. What client are you using to access Roon core?
  4. What brand of NAS are you using?
  1. Where did you install Roon core?
  2. Roon core is installed on what platform? (Windows, Linux, Apple)
  3. What client are you using to access Roon core?
  4. What brand of NAS are you using?

Core Machine (Operating system/System info/Roon build number)
Windows 10 i7 PC with 16 GB memory.
Latest Roon down load of 4 days ago

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
All PCs and NAS are wired (except IPAD a as a control device). .
Other PC s Win 7 but not used at this time

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
All music on NAS device - UNRAID. Very stable over several years and unchanged recently

Description Of Issue
I posted a long description of problem this this am - don’t see it now so this is a redo of the post

“Library data on NAS drive appears/disappears.”

New to Roon only a few days.

Have got things to work just fine with Tidal and Roon. Played with it a few hours last pm. No apparent problems.

My UNRAID NAS is working and other software (JRiver) can access it without issue

Shared NAS drive is pathed from all PC’s on network as “R:” Seen in Windows Network, in Explorer, etc

Roon saw drive “R:” along with “C:”, “D:” drives as sources from which to scan music.

My music is 18k albums

I had ROON Core machine (Windows 10, I7, 16 gb) access R drive to incorporate into Roon library. started scanning and was incorporating 40 k files when Ieft

I figured it would take hours and left for about six

When I returned, ROON was no longer running

When I tried to start Roon again, it would initiate (long time to get going) and then quickly disappear. No error message

Finally got Roon to “run as administrator.”

All of the music on “R:” was not seen in library and “R:” no longer visible as source of music from which to get music into Roon library. Drives C and D still acceptable choices. Put some music on C and it incorporates into Roon library with no issue.

Rebooted PC, etc. no help

Deleted all the data paths with references to “R:”.

“R:” is NOW viable option from which to incorporate music.

Trying putting music into Roon library again but same problems as above

Official name of NAS is MYNAS1
Tried that in the Use Network Share field (\MYNAS1) - does not work. I think error was invalid path but not at PC now so not positive.

Any other suggestions?


I strongly recommend that you move Roon core to Unraid. Go to Apps on Unraid and search for RoonServer


Very stable release. Specify config location on cache drive and your music folder location.

You should also enable Samba 1 on your home computers. Go to Control Panel, Programs, Programs and Features, Turn Features on and Off and search for SMB1. Windows 10 disabled with feature some time ago. Once enabled, after reboot, you will not have any issues accessing Unraid server.

You do not need to mount Unraid shares on your PC.Instead use network type path

Your computer should be able to resolve this address without any problems.!

I appreciate all help

Without changing anything, this is how my PC is configured already. Should this be ok?


In my previous attempts, I was scanning about 10 directories with 180 k songs simultaneously.
I have now scanned 3 directories, one at a time and this seems to be stable. Could I have “overwhelmed” Roon?

Thanks for help and suggestions