Networkaudiod fails to start on boot [Solved]

Continuing the discussion from Raspberry Pi as an HQP NAA:

Hi, would it be possible for someone to elaborate
a bit on how to get network to start synchronously at boot time so that
networkaudiod does not fail to start? I tried to read the man pages, but
couldn’t understand most of it.

Also, if I have multiple pi’s working as NAA’s is it possible to give
each one a different name so that I can identify which is which from
the HQPlayer NAA drop down box and select the specific NAA I want?

Thank you!

Hi Hammer,

Networkaudiod is a Linux daemon. I understand that once installed it will always be running in the background in the system. (Edit: Ah, I see the timing issue sorry. Best I leave this to those more Linux savvy).

You can name NAAs using the Network Naming feature in HQP under Tools. They will then appear under the assigned names in the Device drop down box.

Edit: Merged from the NAA topic

Hi, solved issue by adding “post-up systemctl start networkaudiod” in the interfaces file. I guess this waits until the network is up and then starts networkaudiod. Thought I’d pass it along in case others are having the same issue.

not sure if this is the most correct way to fix the problem, but it works! Wandboard Quad with a linear power supply sounds great!

1 Like