New Albums From Qobuz Unavailable on Roon

Today I tried to play the album “Come Away with Me” by Norah Jones on Core through my Nucleus. When selecting “Play Now”, kept getting an error message saying “This Track Not Available From Qobuz.” I was able to play that album when streaming directly from Qobuz outside of Core. I have played this album many times previously through Core. Has anyone experienced this?

If it’s this one you are playing, it’s because this particular version has been removed from Qobuz and replaced with another one.

You need to remove (from Roon) the unavailable version and replace it with whichever one is now available from Qobuz.

These things happen regardless of streaming service and it won’t be the last time you will come across this :slight_smile:

1 Like

There is also still a 24/192 version available on Room/Qobuz.

This is very interesting information!
Replacing an entire album is comparatively easy.
But if you, like me, have created several playlists, this “not available” and the associated re-importing really annoying.

Has anyone experienced this (with any album) when playing Tidal through Roon?

I would even go as far as saying it happens more often with Tidal :slightly_smiling_face:

It’s an aspect of all streaming platforms. Versions of particular albums are licenced/unlicensed for various reasons and a various times. Sometimes an album is simply removed without a new version being added. The platforms can only work with what labels and artists authorise.

1 Like

It seems to be a common problem that new albums and tracks, which are already available in Qobuz’s own app, are not available when using Qobuz through Roon.

Today I tried to play Porcupine Tree’s latest single Of The New Day through Roon + Qobuz and it says it’s not available. In Qobuz’s own app the track is available.

It’s available for me and plays fine.

1 Like

And I still can’t play it:

So what’s causing this?

Different Qobuz locations maybe?

Plays for me in USA.

1 Like

Can you remove the album from your library, restart core and then add it back on again?

As I wrote earlier, it plays and finds just fine on native Qobuz app. The problem is with Roon + Qobuz. I’m located in Finland.

@RBO I’m not sure why I should restart the core to make new music available on Qobuz. Most of the new music is found but sometimes there’s a delay between the native app and Roon + Qobuz.

The release you have added won’t be available fully until the summer. As you can see by its date :slight_smile:

The reason I am asking you to do this is because you have probably added it to your library before the track you want to play was released and for some reason Roon has not refreshed this release.

Just try it. Won’t hurt :wink:

I’m fully aware that the whole album is only available in summer. But the first two tracks are released and available on Qobuz but not when browsed through Roon.

I’ll try to remove the album from my library and re-add.


So I removed the album from my library but after that I couldn’t find the album at all through Porcupine Tree artist page and discography. When I type the album name in the search field, Roon found it and the album and now the second single is also available.

So I think Roon can’t update the album if it’s already added in my library.

@RBO My roon core runs on QNAP and it stops every night and restarts in the morning, it’s scheduled to do so every night so it’s not about restarting the core.

Stop being so stubborn and just do it :rofl:

Glad it worked :stuck_out_tongue_winking_eye: