New NUC install won't boot

Having a problem setting up my new NUC - installed the m.2 drive, RAM and SSD into the NUC, when I did the first boot up I get the following sequence:

  • Intel NUC splash screen
  • Checking Media Presence
  • A bootable device has not been detected

That’s as far as it gets, it doesn’t boot into bios.

Any ideas please?

Memory and drives were installed carefully and using an antistatic strap/mat bonded to mains earth, so I don’t think I destroyed anything in the process.

Update:

  • Have tried re-seating the m.2 drive, this has not solved the issue
  • Have entered bios using F2, under advanced -> boot order I only have LAN, if I check legacy boot, I get ‘no boot drive’

Further update:

Under Boot Configuration -> Boot Devices ‘Internal UEFI shell’ is not checked, only USB, Thunderbolt Boot, Optical, and Network Boot

Should I check Internal UEFI?


You should have come across an f7 prompt as you were booting up originally.
Did you see that prompt and hit F7?

Thanks for the reply.

No, there was no F7 prompt on initial boot, just the sequence I described.

Should I go ahead and hold down F7 while booting now?

I noticed that both m.2 and SSD drives were showing in bios, so not sure what the problem is here…

Yeah, I’d do that. It can all flash by pretty fast.

1 Like

Thanks will give that a try.

Hi

Apologies if I’ve misunderstood but if this is a first time build then you won’t get a boot drive until you install ROCK via a USB stick.

3 Likes

Really? If so that’s a relief, as I updated the bios but still getting the same error!

In that case, the ROCK install guide is misleading - " At this point, there’s no operating system on the NUC, but it should boot and you should see the Intel welcome/splash screen. Note that this screen should also have the correct keyboard shortcuts for entering BIOS which you’ll need in Step 2." I don’t get the keyboard shortcuts for entering bios, although I can do this by holding them down.

So, OK, I can go ahead and try to install ROCK anyway despite this error message?

I think they mean it will perform the startup ‘boot’ process and show the splash screen. It will not boot to an O/S as there is none at this point, but will boot enough to allow you to get into the BIOS as required by step 2.

Carry on and once you’ve booted the USB key and installed you can then reboot into ROCK… any issues, just ask :+1:

1 Like

Now I’ve had dinner it makes perfect sense - ROCK is the OS. Too many years auto-updating Mac OS and not installing anything from scratch.

Thanks for your help, guys.

1 Like

OK, I think I spoke too soon. Step 2 of the ROCK install guide includes setting BIOS options. Step 3 of updating the BIOS for ROCK (https://kb.roonlabs.com/ROCK:_Updating_and_Configuring_BIOS_On_Your_NUC) is setting BIOS options, including dragging the boot order of drives, but I have no drives showing at all under boot order or boot configuration. Is that really normal?

Also, I can’t boot from the ROCK install USB drive I made using Etcher…

Not really. No drives listed means the computer is not seeing the drive you installed.

Very weird, I now have it working, but more by luck than following the instructions. In my case, f10 only showed Network boot, not USB or SSDs. I then went into BIOS again and set boot from USB first. This then allowed me to boot from the ROCK install USB. Then going into BIOS the m.2 and SSD drives WERE showing and allowed me to drag them into boot order. I was then able to boot from USB install ROCK and now everything seems to be installed. No idea whatsoever why I couldn’t boot from USB or see the drives in boot order/boot config before this…

1 Like

They weren’t listed in boot order/boot config, but were present under SATA and PCIe tabs, which seemed odd to me.

All seems OK now but only after following the weird procedure above.

Glad you got it sorted :slight_smile:

1 Like

It does seem that Roon needs to revise and improve the installation instructions. There are too many people that are having a hard time, especially on the step(s) @ScreenMachine had.
I don’t know how much the BIOS setup situation has changed since the ROCK setup guidelines were first done, but virtually everyone will be doing it with 8th Generation Nucs from now on. The user should not have to ‘figure it out’ by poking around through the various tabs and end up in a state where they don’t really understand how they made it work. The user base can’t be as helpful as usual because we (mostly) went through this just once and now the Nuc is tucked away somewhere without a screen or keyboard.
Maybe outsource this to Ikea, and include an allen wrench. :wink:

2 Likes

I’ll write up the steps I actually took properly, if it helps?

1 Like

I think that would be very helpful. To help the most people it would need to get into the KnowledgeBase. But it’s amazing how much you can pull up from the forum through the search function or even Google searches.
It doesn’t help that the demographics for the Roon User base tend to coincide with that time when memory starts to slide…

1 Like