New NUC - Just Move and Go?

Hello - I have an older NUC running ROCK - its ethernet port was failing, so I’ve been using a USB adapter with OK results - but I want it right. So I’ve just ordered a new, Roon-supported NUC. Can I just move the RAM, SSD and USB SSD (music storage) to the new NUC? Will it simply boot? This feels like a dumb question, but I’m not sure why it wouldn’t work?

depends on model of old nuc and new nuc… you need to provide more information about old and new setups

Thank you, @danny. Apologies - here’s the info:


Each are barebones kits; I added RAM and the internal SSD to the original and I’m also using a wonderful external Toshiba USB SSD for storing my music library.

Not sure what other info to provide - but thanks in advance and I really appreciate the assistance.

The SSDs, for sure

The ram, probably not. but if the NUC8 is forgiving on speed, you can.

This is very helpful - thank you. Especially because it’s the opposite of what I would have expected - I would think “RAM is RAM” (at least modern RAM).

So I am clear, you are saying that:

  1. The internal boot SSD can be transferred from old to new NUC, and the new NUC should run ROCK just fine; and

  2. The internal RAM from the original NUC may or may not work in the new NUC. For the record, the RAM I’m hoping to move to the new NUC is:

Crucial 8GB Kit (4GBx2) DDR4 2400 MT/S (PC4-19200) SR x8 SODIMM 260-Pin Memory

Thanks again, @danny!

I would have thought you would need to reinstall the OS, if the new NUC requires different drivers for the internal hardware. Interesting that @danny didn’t think this was needed.

That RAM should work fine. it’s overspec’d for the NUC6 but perfect for the NUC8

OS has it all already. The install is super fast (< 30s usually) because its a simple copy of everything.

Wow is this frustrating, and for reasons I did not expect. With @danny giving me the impression it was going to be swap and go, I tried it this morning. Beyond zero.

  1. I confirmed I had a successful Roon back up last night
  2. I removed the RAM and internal SSD from the old NUC and put both in the new NUC
  3. Hoping I’d get lucky, I connected the new NUC to my LAN via Ethernet and powered it up
  4. Sure enough, I got the “No Boot Device” error from the Intel NUC’s BIOS
  5. No problem - I figured I’d just hit F2 and change the boot sequence to look at the internal SSD
  6. But - and this is the crazy part - I cannot access the new NUC’s BIOS - I’ve hit F2 at every conceivable time (including the obvious, at the Intel NUC splash screen), but I cannot access the BIOS. Yet I can hit F7 and update BIOS (done), and hit F10 to pick a boot device - but only LAN options are shown, and not the USB stick I’ve inserted with the ROCK image (which should already be on the internal SSD, but I’m trying anything at this point)

I’ve even tried a diff keyboard, on the off chance the original’s F2 key is broken. But no go. So to summarize: I can access parts of the BIOS, but not the main part; the USB port works, as I used to update the BIOS; the keyboard works - in fact, two of them work

I’m sure this is something super basic - but for the life of me I can’t get this new NUC to boot, or even access its BIOS to set the boot sequence. Maddening . . .

Boy, that is strange.
When you’ve used the F7 or F10 key to get to other menu areas, have you tried pressing F2 from there?
There’s another way to enter the BIOS. With the NUC off, hold the power button for 3 seconds. Try seeing if FastBoot is causing the trouble:

Fast Boot in BIOS reduces computer boot time. With Fast Boot enabled:

  • You can’t press F2 to enter BIOS Setup.
  • USB mice and keyboards are unavailable until after the operating system loads.

Disable Fast Boot from the power button menu.

  1. Access the power button menu with this sequence:
  2. Make sure the system is off, and not in Hibernate or Sleep mode.
  3. Press the power button and hold it down for three seconds and release it. The power button menu should display.
    Tip: If the system boots to the OS after trying this procedure then you didn’t hold the button quite long enough.
    If the system simply shuts down after trying this procedure then you held the button too long (longer than 4 seconds).
  4. Press F3 to disable Fast Boot.

What is the resolution of your monitor? Is it sufficient to display the Visual BIOS?

Bingo - it was last issue. Crazy - I was using a test HDMI monitor that must not support the Visual BIOS rez. Connected the NUC to a “normal” HDMI computer monitor and I’m in.

Crazy they’d use different resolutions for diff parts of the BIOS.

Thanks all!

Success - but I’d like to document the bumps in the road I hit in the hope of helping others.

As a reminder, I wanted to move the modern RAM, modern internal 250 Gb SSD (housing ROCK and the Roon database), and a modern external USB SSD (my music library) from an older, Roon-sanctioned Intel NUC to a newer, also Roon-sanctioned, Intel NUC.

@danny indicated in this thread it should work, and it does, but I ran into a couple of issues.

First, and the biggest, was that the monitor I was using to get the NUC configured didn’t support the resolution used by Intel in its “Visual BIOS”. What was totally crazy is that I’d get the Intel NUC splash screen, and could go into other, BIOS-like screens via F7 or F10 - but my monitor couldn’t handle the Visual BIOS, thus F2 appeared to do nothing.

Connect to a diff monitor - no problem - made the Roon-suggested BIOS setting changes, saved and exited. Almost, but not quite there.

When I attempted to access Roon once the Core had started, I got a Roon Log-In screen. I successfully logged in, but it was not until I restored from last night’s back-up that things got straight.

Once the backup was restored, I logged in, and everything is exactly like it was yesterday, except my ROCK Core is on a 2020 NUC. Very pleased, and thanks to all for the help.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.