New NUC ROCK user - looking for help with how to upgrade BIOS from CAP file

Hi. I am moving my Roon installation to a NUC10i7FN, newly bought and have been poring over the knowledge base articles on how to install ROCK. I am stuck at the very first section of how to update the BIOS.
I have gone to the intel site and found the downloads for my device and the latest BIOS version seems to be v. 0044. I can’t find a .bio file only a .cap file and when put onto a USB stick and booting up with fn7 there doesn’t seem to be a readable file.

I can’t find any specific instructions that I can understand to tell me if I have to change the file type somehow or what other steps I need to take. Can anyone help a total novice who is clearly out of his depth here? Thanks

I am by no means an expert, but I don’t believe a BIOS update is necessary anymore. Try skipping this step, and see how you get on.

Intel appear to have changed the BIOS update process for the 10th generation NUCs. What used to be a .bio file is now a .cap file.

I’m assuming that you are following the instructions given in the update release notes (both methods), so I’m not sure why it’s not working.

However, as @mikeb says, you could try skipping this upgrade step entirely, although, reading the release notes, there appear to be some fixes in v0044 that could be worthwhile.

Thanks to you both. I decided to try to move on without updating bios and have hit a couple more roadblocks.

Within the bios settings I can’t set to legacy rather than Uefi booting. The options are not selectable.
My ssd doesn’t appear as a bootable option yet as it has no OS on it but is in the hardware list as enabled.

After that I tried just installing ROCK from a flash drive made with etcher. First time I tried, although the USB stick appeared as an option it would not boot from it and threw me back to the boot option screen. Tried a different flash drive and that is now failing to boot also but showing a flickering screen with white text “checking media presence, no media present. “

This last bit feels like it is likely my fault in preparing the media but I followed instructions to produce a bootable stick using etcher.

I am a longtime Mac user so I’m sure you can fee the edges of my experience here.

I’m going to redownlod, reformat and Re burn the ROCK installer and have another go.

Any other ideas out there?

I think there’s a trick to getting the legacy boot set - there’s a post here on the forum where someone has given the details. Sorry, I’m not a 10th gen NUC user, so I don’t know the details.

I think that this thread and the posts around the link in particular will help.

1 Like


Thanks again for the tips. The thread you mentioned confirmed why I was seeing the lack of configured drives. I had just about figured that one out.

The two other tips I needed spelled out where ensuring USB priority booting first and finding a way to change to legacy booting in BIOS which I found here:

Needed to change to legacy power management before I was allowed to change to legacy booting. As soon as I did that I could boot from the USB and install ROCK.

Now just migrating my database. Thanks everyone so much.


Good stuff, enjoy listening.

@danny can we get the instructions updated for 10th gen Nic’s please


When I installed ROCK on my NUC8i5 I ignored the bios update suggestion and have been running just fine since.


The bios updates were needed in the very early days of the 7 series NUCs that were already out in the wild before ROCK was made available.

While it is still probably a good idea to keep the bis up to date I haven’t updated mine on my 7 series NUC for years now.

It was the 6th generation NUCs… A problem with the voltage regulation circuitry meant the NUC could be bricked. Intel brought out a BIOS update that had to be applied to all NUCs out in the field.

As mentioned elsewhere here, I think its high time for the instructions to be updated, and the BIOS update inclusion causes more trouble than its worth.

Probably something to the effect of if you are having problems check your bios is up to date.

1 Like

An update to the instructions to stop attempts at BIOS updates would definitely helped but the key step that stopped me getting on was switching to legacy boot. It wasn’t clear on my machine how to do this - seems like newer machines are deliberately set up to prevent this change without first chnging power management. As soon as I was guided to how to do that the installation took 5 minutes.
Working like a charm now. Thanks to all.

1 Like

Don’t understand the reticence about doing this. Another mystifying Roon thought process.

I’ve not got strong feelings about the guide but I’m more positively inclined towards keeping a BIOS up to date. Changes tend to include non-specific security improvements as well as more tangible benefits. One example is network wake from sleep, which often seems to take a few versions to get right. Fan control is another popular tweak. It’s not unusual to see Roon issues on here quoting problems with similar. It’s usually more important during the first year of a board’s life when serious issues can be found.

The best policy is to read the CHANGELOG and decide.