New NUC10I5 - cannot set Legacy Boot in BIOS no matter what

I am trying to set up ROCK on a new NUC10I5FNK4. However, I cannot change the BIOS from UEFI to Legacy boot. I have tried all the recommendations at Legacy Boot is Greyed Out in BIOS Setup (intel.com.au) but the Legacy Boot option is still disabled. I have a 256GB Adata SX8200 NVMe drive installed. I have also updated the NUC BIOS to the latest version. Still no luck.

I have seen discussions on the internet that claim NVMe drives require UEFI boot. Should I try a SATA M.2 drive instead? I have not even got the ROCK OS loaded yet and so think this might not really be relevant - or will the BIOS sense the drive is NVMe and enforce the UEFI boot option?

Any advice? Is it possible that Intel have completely removed Legacy boot from the BIOS for NUC10?

If not, my only alternative would seem to be that I have to install Windows and run a Roon Core instance.

What a difference 10 minutes of reflection makes. Please ignore my post - I found the switch to change Legacy Boot is not actually in the Boot page of the BIOS. Having set it on, the ROCK install worked perfectly.

2 Likes

Been there :slight_smile: glad you got it working! Took me a couple hours.

I’d love to see the kb article updated. Too many people get stuck here, and that’s easily solved.

Where is the setting found?

The Legacy Boot setting is actually a checkbox on the Boot Priority screen (Boot > Boot Priority). The Glossary for NUC Aptio-V is here: NUC-AptioV-BIOS-Glossary.pdf (intel.com) - see page 41. I found the setting only by methodically opening every screen and option I could find, no matter how irrelevant it seemed. The values for Secure Boot, UEFI Boot and Legacy Boot that you can see on the Boot screen are just “information” - so cannot be changed from that screen, even though other items in the same list are for setting options! It is really obscure and confusing. Here are some screen shots from the Glossary.

For anyone wanting more detailed instructions on configuring BIOS and installing ROCK, with screenshots, please join the Roon Users group on Facebook.

Additionally, if at Roon enables me to SSH to ROCK, and get nice, clear screenshots, I’d be willing to write instructions for all NUC installs Roon supports.

1 Like

SSH access to ROCK or Nucleus for that matter, is not going to happen…no way no how, this has been said many times by Danny.

The help pages need updating, this has been said many times too.

1 Like

There’s no part of ROCK setup that uses SSH, so I’m not sure how that would help. What you need is an HDMI capture card so that you can get clear screen grabs of the BIOS screens. This one is probably more than adequate.

I understand ROCK doesn’t allow SSH. That’s why I asked. I’d even be willing to write the documentation at no cost for Roon. Keeps me off the streets. Where’s that NDA?

No point responding. I didn’t expect to hear back from anyone reminding me that “The help pages need updating, this has been said many times too” and “SSH access to ROCK or Nucleus for that matter, is not going to happen…no way no how, this has been said many times by Danny.”.

You never get unless you ask. I assumed the lack of response was the answer.

@Neil_Small there is nothing stopping you from writing something up or doing a YouTube of it and posting on line and linking in a post here…go for it.

What is the need of SSH for accessing a NUC Bios? The Bios is accessed before the operating system starts up and is accessible without any operating system installed at all. Also it has nothing to do with Roon Rock except that ROCK has some requirements that need to be set in the Bios.

2 Likes

Exactly, no ip stack in a bios, so ssh is a non-starter. Lots of hot air, and little substance.

1 Like

What would you hope/expect to do with ssh access?

good point!
even with ssh you cannot grab the bios screens to document the change to legacy boot.

Originally, I hoped to get additional data to accurately verify answers to questions about the OS, build versions, cpu utilization, BIOS changes to fan/cooling options, multichannel etc. However, at this point I realize this would be outside my right to disclose anything about ROCK.

My post was poorly worded, and I thank @David_Snyder for pointing out the obvious mistake (David and I have discussed video capture is the past). Yes, I can get the BIOS screenshots many different ways, and none of them require SSH access. Therefore, please disregard my question.

Thanks for your time and the reply.

1 Like