New Pi 4 Build with Touchscreen- no display

Hello. I just finished a build with a new R Pi 4, 7" touch display, and RoPieee. Everything went smoothly, Roon recognizes the zone and I get great sounding audio via USB. My problem is that I cannot get the display to show anything but the “Connection Failure” screen- sometimes it changes to the clock. I have tried to enable the RoPieee extension in Roon Settings → Extensions, but nothing shows up. Any ideas as to what is going wrong?

Maybe reinstall the RopieeeXL software.

  1. enable the extension
  2. configure the proper zone in the web interface

That’s the thing. No extensions show up in Roon under settings/extensions. I have reinstalled the software once and the zone is configured in the web interface.

By the way, thanks to the creators of this awesome software! This came in just under $200 and sounds great. If it helps, here is a screenshot of the setup screen. Also, this case: works great.


This text will be hidden

Can you send feedback? It’s on the ‘advanced’ tab.

Done. Thanks very much

Logs have been sent to RoPieee HQ with unique identifier ad54b69db16143ce

Please leave a mail or a note on the Roon forum with this identifier. Thanks!

Roon needs all devices being in the same network.

Your TV:

While this theoretically can be the same network, the usual netmask used with such addresses is, which makes the two devices (and your iPad and your Core maybe too) belong to different networks.

1 Like

Thanks. I wonder if this may be because of my Eero mesh network.

Hmmm… for some reason the remote extension can not connect to the Roon core. Hence no information can be retrieved and you get the error code.

And it it’s indeed weird that your iPad is on a different subnet, although I can’t think of a reason why that should interfer with the extension trying to connect to the Core.

Solved. While investigating, I noticed that my Mac Mini that’s running core was disconnected from ethernet and only on WiFi. Connected the cable and all is working. Thanks for your time! Donation made.


Funny thing… The display now works beautifully, but has lost touchscreen functionality. It worked a few times, but now does nothing. I wonder if this can be a network issue as well, or possibly bad hardware?

Problem solved. The touchscreen control connection had loosened.

1 Like

I’m getting back to using this again. I just reflashed and installed. The screen just hangs on:
“We’re ready. RoPieee is RUNNING …”
Any advice?

Did you pair and enable the extensions?

Don’t forget naming must be exactly the same

Thank you, but that’s the thing. It doesn’t let me get that far. I can’t enable any extensions in Roon. It doesn’t let me get to the IP address stage. It just hangs there.

It’s not hanging, it’s operational.

Probably the screen is not detected during installation, hence it’s not working.

Solved- Bad network cable used during installation. I appreciate the assist, though. All working well now.

Hope you tossed that cable never to be used again. Cut off the ends so some other poor Bugger doesn’t use it too