New Pi Problem - Just Pops No Music

I just built a new Pi4b with RopieeeXL. The install went smoothly and it’s running on WiFi hooked up to an SMSL SU-8 DAC. All I’m getting are periodic pops. I hooked the SMSL to my Windows 11 PC set as an endpoint in Roon and it plays perfectly with the same cables. I tried rebooting the Pi and got the same results. I’ve swapped the cables a couple of times with no luck. Just wondering if there’s something in the logs that might help. Thanks.


Update, I moved the whole shebang into the room that contains the router and hooked it up to another amp. It plays perfectly. The problematic hookup is only in the next room. There’s one wall in between. It’s on 5GHz channel. There’s a Pi3b in the same room that plays just fine also on 5GHz.

A Network problem obviously, unrelated to ROPIEEE… :wink:

Is your Pi in a metal case? That can weaken the signal.

Ropieee does support some external USB wifi adapters, which fixed a wifi problem for me.

Also if you have 2.4 GHz it may get through the wall / case better.


You might want to use WiFi Analyzer (or your Wifi mapper app of choice) to see how “busy” the WiFi is in your area and change the router to a channel that is not so congested? You can also see the signal strength in WiFi analyzer to see if it is truly the issue.

Lastly is there any way to wire the Pi? Would be much better… :slight_smile:

All good responses, but as I said in my original post I’ve got a Pi3b in the same room running on the same network with the same wifi dongle (tp-link AC1300) and it works fine. I also have a Pi4b in another room with the same dongle and it works just fine. I had EOP adapters for that room that worked really well. Then I added tube amps and they were picking up RFI from the adapters so I ditched the EOP. As for switching to 2.4GHz, my Netgear Orbi doesn’t support that.

I guess I need to flag @spockfish for help.

I think you‘re facing a hardware issue, try swapping the dongle around the units.
Anyways, what‘s wrong with the Pi‘s internal wireless implementation, forcing you to use dongles?
They work like a charm on 5GHz through walls here…

1 Like

You know you’re right. I’m out of town but next try will be without the dongle.

Marin_Weigel was correct. It was the dongle. Took it out and used the onboard wifi and it works perfectly. Thanks for pointing out the obvious Marin. :wink: