New Raspberry Pi User Cant "connect to the HQ Player"

Roon Core Machine

PC.

Networking Gear & Setup Details

Connected Audio Devices

Raspberry Pi with an AlloDigiOne as an endpoint.

Number of Tracks in Library

Description of Issue

Everything seems to be setup correctly, but when I play a song, I get an error.

“playback failed because Roon couldn’t connect to the HQplayer”

Any ideas?
Thank you

Can you play any audio from the pi itself? E.g. open up youtube in a browser and watch a video, does the audio come out of the allodigione? Im assuming you have a desktop os installed on the pi.

Brian, I am moving this to the RoPieee category where other users, including @spockfish, may see this and offer some ideas. If that does not solve this, then moving to the HQPlayer category may be another option.

I’d start with confirming it’s set up and running correctly, follow info here RoPieee | Getting Started

Thank you. I followed the directions. It’s how I ended up in this forum. It was the last step:/

I would make sure your turn off windows firewall setting to troubleshoot…if it all works then you have a firewall settings/permissions issue

… or check that the Windows network type is Private and not Public as if it is Public Windows firewall will block any incoming connections … sometimes Windows change the network type to Public on its own …

Thanks
I’ll try this

Are you running HQP as your selected zone?

No. I changed my zone to to time zone

OK, I think we have some confusion here. I was referring to the Roon Zone - essentially the playback device that you were selecting to play your music through.

Your error message says that Roon is expecting to find a copy of HQPlayer running on the network but cannot see it. If you are running HQPlayer in your system then you need to make sure it is set up correctly.

You stated in an earlier post that you were running RopieeeXL as your endpoint on a Raspberry Pi. If you are not running HQPlayer then do you perhaps have the HQPlayer NAA toggle engaged? You can see this in the Ropieee web interface under the RopieeeXL tab.

Thank you. I’ll try this