New ropieee install and wifi

i have installed ropieee on a new rpi3 and enabled wifi and entered ssid/wpa psk via ropieee web config (with ethernet cable connected).
after reboot, with ethernet unplugged ropieee won’t connect to wifi, had to add ssid and psk into /etc/wpa_supplicant/wpa_supplicant-wlan0.conf - then after reboot ropieee connected to wifi correctly.

i belie once the wifi is enabled and configured via web interface it should automatically populate wpa_supplicant config so manual step as i had to do should not be required?

Correct, manual update of config is not necessary, by design. Strange that this didn’t work for you.

Maybe send a feedback to @spockfish so he can look at things