New Router, Cannot Connect

I had a Huawei B525 and Intel NUC running ROCK working fine for a long time. I got rid of the B525 because it often turned off the WiFi. Plugged in anew B628 Huawei yesterday everything in the house connected but cannot connect to Core on NUC even though the router can see it.
Do I have to change something on the router ?

I assume you rebooted your NUC? If not, I would try rebooting both router and NUC.

Yes everything rebooted.
I have an update. I cannot now use the PC as a core, I get the same result. This used to work before too.

Might be a firewall issue.

@Murray_Mackay, can you provide any additional information about your networking environment in your home? There may be a IP address conflict or some other issue, and as @Jim_F notes, you also may need to check your Windows firewall settings again on your PC Remote to ensure there are exceptions for roon.exe and raatserver.exe.

Can you see your network from within the B628’s administration page? What local IP addresses are assigned to your LAN? Still


does your core still reside at does “ping” reply or time out?

I’d be shocked if it got the same IP address.

I would log into your new router and see what IP was assigned.


Solved. Had to create a new APN profile. Maybe because router is not from EE ?

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.