New Router - new problems with ethernet connectivity to Devialet Expert Pro... (but Roon works)

Roon/Devialet new connectivity problem for me… this has also been posted on Devialetchat forum…

Having spent probably 12 hours trying to fix my latest problem, it is time to ask for further advice…

System: Expert Pro 1000 - Roon on NUC - Synology NAS - switch (simple) - all ethernet wired
Connected to rest of house LAN via a hard-wired TP-link router configured as a wireless repeater
Connected to main router (now new Draytek) - hard-wired

This physical setup has worked really well for last 2-3 years (apart from the occasional minor Dev issues which we are all familiar with). Until I replaced the standard TalkTalk router last week with a dual-purpose DrayTek which combines the normal ADSL line with a G4 connection (using an unlimited data SIM inserted). This was done, as our 4G signal is about 50-80Mbps, versus the landline about 8-12Mbps. Apart from the issues with the Devialet, it all works really well; we now have home internet, wired and wireless, which is 5+ times as fast as before.

However, this has completely scuppered my Roon/Dev setup - I continuously get the ‘Device in use’/‘Roon lost control because input was switched’ etc error messages whenever I try to play a track. No exception. No streamed music at all, whatever I do. I have trawled the Roon and Dev forums and these messages appears to be a fairly common issue - but from what I can gather, usually intermittent.

I have done the following, and nothing has changed the situation:

  • Discovered the latest Dev firmware and uploaded it (without a problem) - 13.2.0
  • Tried both fixed and dynamic IP addresses for Expert Pro
  • Reverted to firmware 13.1.3 (again uploaded without a problem)
  • Ensured wifi is turned off in the configurator
  • Checked that vinyl and analogue line inputs work properly; they do, Dev plays them fine
  • Done multiple full power offs (turned of at wall socket and waited for a few minutes)
  • Disabled and re-enabled Ipv6 on the new router
  • Reloaded Roon’s operating system, all settings and connection to NAS, cleared caches


  • As suggested in a thread somewhere, downloaded the Remote app onto my iPhone. Interestingly, the ethernet connectivity problem appears to be only ‘one way’, i.e. towards the Expert Pro. When e.g. inputs or volume levels are changed using the (aluminium) remote, this is reflected on the iPhone app display. However, any commands made from the phone remote have no effect (e.g. volume change, input change or power off). So, it appears there is some connection via Ethernet.
  • The router recognises the presence of the Expert Pro in its connected list, correctly attributing either a fixed or dynamic IP address as requested.
  • The Roon setup as such seems to be working fine; it recognises the NAS, accesses Tidal and Qobuz, and successfully plays them through e.g. my iPad or phone when requested. It recognises the presence of the Expert connectable by AIR in its ‘Audio’ settings (also with Airplay as a separate option) and allows me to request connection.

I would be most grateful if anyone could suggest a further approach. I am not desperately keen to go and rip out the new Draytek router, as absolutely everything else about it is absolutely fine, and it is a huge improvement…
Should I consider USB connection…?

Thanks in advance for any brilliant suggestions!

Are you able to replace this with a cabled connection, even if just as a test?

Dear Carl, thanks for your reply.

I suspect I may not have been entirely clear in my description of my wiring…

Main (now new) router/modem is hard wired to TP link router, which has been reconfigured to provide wifi access to the other half of our house, and does not form a network of its own. The TP link is also hard wired to a simple switch in the room where the sound system is. The Roon NUC, NAS and Devialet are all ethernet wired to this switch.

In other words, there is an ethernet wired pathway all the way from the outside world to all the hifi components. The only devices connected by wifi are controlling devices, i. e. phones, iPads etc.

Does that make sense, and does it change any suggestions you might have?

I think your hardwired ethernet chain is this …

DrayTek --> TPlink --> Switch --> Expert Pro 1000, Roon on NUC, Synology NAS
  |           |
 WiFi        WiFi

With both the DrayTek and TPlink providing WiFi Access Point services.
And the TPlink also acting a Switch.

I would suggest, as a test, removing the TPlink and connecting just the Switch into the DrayTek.
If that helps, then connect both TPlink and the Switch directly to the DrayTek.
If that’s not possible (not enough ports on the DrayTeK) consider adding a switch.

DrayTek --> Switch --> Expert Pro 1000, Roon on NUC, Synology NAS
              |--> TPlink 
  |                |
 WiFi             WiFi

Side note, I’ve had trouble in the past when using routers as switches, they should would fine, but often these multifunction devices are built on a tight budget and implementations / compatibility can vary.

At least by trying this you will see if it make any difference or not.

Hi Carl

Yes, your schematic representation is spot on.
I will find a way of doing what you suggest. It will be interesting not because there are not enough ports on the Draytek (the ethernet cable to the TPlink is in fact the only on in it), but more physical separation - the two ethernet cables between Draytek and switch are over 20m each…
Seems there is going to be a bit of carrying stuff around :grin:

Or a quick little purchase of a switch on Amazon.

And you think the problem’s with your D1000?, which you’ll want to be running v13.2.0. There’s probably some sort of anti-broadcast setting in the DrayTek. Make it simple, complicate the network til it breaks. Step back.

In response to the above, I have now inserted a simple 10/100 switch exactly as per Carl’s second diagram. no difference yet. Also turned off firewall on router (suggested on Devialetchat forum) and power cycled by physically unplugging. I have reinstalled firmware 13.2.0 as per Mikeb’s suggestion. Any comments on IP addresses fixed or not? I have seen both suggested.
If all else fails, I might have to reinstall my old router to see if that is the problem zone. Don’t fancy it, given how long the Draytek took to set up, but it might be necessary :roll_eyes:
At least I can save the settings Isuppose.
Thanks everyone. Really tedious, this!

Actually, there are two switches, but the TPLink is on the side now, rather than in series, as per the second diagram.

Another possibility, I suppose, might be to get rid of the TPLink altogether by setting up a mesh wifi network entirely driven purely by the DrayTek. Perhaps those two just don’t like being on the same LAN…

Managed to solve the problem - thanks everyone for their contributions!

I have reconfigured the secondary router (TPLink) to act as a router again, rather than an access point. The Primary router (DrayTek) is connected to it in a LAN to WAN configuration, with all the IP addresses on the secondary network now in the 192.168.0.x format (as opposed to 192.168.1.x on the primary network). The internet access on the secondary network is therefore the same as on the first, providing much better streaming and upload speeds. And, the Expert Pro is happy!