New RPI 3 Model B+ Launched

This is based on a Volumio experimental build, and the author says he hopes it is a driver issue.

For those who are trying this out with Roon Bridge, what distro are you using?

Is the WiFi good enough to use without a dongle?

Are you using wifi to stream 512 DSD or wired ethernet?

1 Like

I got my Pi3B+ today. Just to make sure I had the latest drivers, I used Rasbian Jessie from the Raspberry Pi site. Because I couldn’t be bothered to figure out how to configure wifi via command line, I used the version with Desktop included.

After booting up to the desktop, I connected the wifi to my 5Ghz AC router. For kicks, I compared the download speeds of the 5GHz wireless to the “gigabit” Ethernet. Surprisingly, they were almost exactly the same, about 70Mbps. (For comparison, my wired desktop usually measures over 300Mbps and my iPhone 8 plus usually measures 200-300Mbps on 5GHz.) So, no real speed benefit for one vs. the other.

I used the command line interface to install Roon Bridge. I find the Roon KB article on Linux to be very confusing, but I just paste these three commands in, one at a time:

curl -O http://download.roonlabs.com/builds/roonbridge-installer-linuxarmv7hf.sh
chmod +x roonbridge-installer-linuxarmv7hf.sh
sudo ./roonbridge-installer-linuxarmv7hf.sh

Boom. Roon Bridge is up and running over wifi. Just to minimize overhead, I also found a setting in the Rasbian Desktop that boots Rasbian up to the command line and doesn’t load the desktop. (You can always re-start the desktop by typing startx at the command line.)

I then plugged up my three USB DACs (Doesn’t everyone run 3 USB DACs on a $37 SBC?) and configured them in Roon:

  • JLH Labs ODAC for my main listening room
  • DragonFly Black for one outdoor zone
  • XtremPro X1 (DragonFly 1.2 clone) for another outdoor zone

All of them worked great. The only problem was when I disconnected them and reconnected, Roon switched the name and settings for two of the DACs. Inconvenient, but not a problem.

After listening on the ODAC via wifi for a few minutes, curiosity got the better of me. I turned off wifi and plugged in to Ethernet. I listened to this for 10-15 minutes, and I didn’t hear any noise or dropouts. I’m not asking it to do anything more than un-decoded Tidal Masters at 24/48, but it didn’t have any immediately noticeable problems in the few minutes I listened. I then turned wifi back on and unplugged the Ethernet. Maybe, just maybe, the sound was a bit better over wifi, but I don’t have golden ears, and this was a really short test.

I’m curious to see if DietPi will come out with an update that is specific to the 3B+, but until then, Rasbian works great!

I’m sure Harry is working on it too so expect a ropieee build coming soon.

1 Like

I posted many times this is lan. Wifi can only cope with dsd256 reliably