New RPi 3B+ DOA?

I got a new RPi 3B+, downloaded the latest image from the website, flashed it using Etcher, powered up the RPi and I only see a red led. No green flashing led.
The Ethernet leds are lighting up very pale, not flashing.
I can’t find the RPi when I scan my LAN.
I re-flashed the image but to no avail.
Is the RPi DOA?
Is there any way I can test this?

Oef… just to be sure you should try with an old version of the image:

Although I’m pretty sure that’s not it. What about power supply?

1 Like

Just tried the old image. No change.
I suppose the RPi is DOA. :roll_eyes:
I tried the standard 2,5 A RPi power supply and a 2 A Audiophonics Linear Regulated Low Noise Power Supply. Maybe not enough power for the RPi 3B+?

before you give up:

  1. Try it out of the case
  2. Try it with a basic OS like NOOBS to see if it runs.

Also, give another SD card a try, it may simply be a faulty card…

I’ll give it another go tonight with Noobs and another card.

I tried Noobs tonight on a new SD card out of the case.
HDMI display stays dead.
Only red LED.
I’ll return it to sender.